3

My Xbox One (about a week ago) has developed a couple of faults.

It won't connect to any controllers wirelessly, and on the few occasions where it does, it disconnects after about 45 seconds or so. I can only use the controller if I use a cable, and even then the Xbox One response to button presses or GUI navigation is slow to non-existent. Although after some testing, I get about 3 min of uninterrupted controls for about 2 1/2mins, so as long as I'm quick I can get things done.

Every app/game I attempt to start (especially Settings, recently) just hangs, then I get a black screen with some seemingly obscure error code saying: "[APP NAME] took too long to start" - And I get booted back to the dashboard.

I've tried all the recommended 'fixes' - Cold reboot. Unplug everything and leave it 30 seconds (I even left it all night last night). Ensure all my controllers batteries/battery packs are fully charged. But nothing helped.

Last night I gave up the ghost and performed a Factory Reset, hoping it would fix the issues, but alas no, I'm still seeing the same issues.

I'm almost out of warranty too, think I've got a few days left.

What can cause this, what should I do ?

  • Is your controller up-to-date? It's the only possible reason I can think of for your controller tripping out. Update Controller. As for the app problems, probably best to talk to Microsoft Support. Their live chats are pretty quick and helpful, and they can sort out a replacement, if needed, then and there. – ImClarky Nov 19 '14 at 10:55
  • Yup. Checked that last night. Hardwired and attempted an update, it tried, but then came back and said it wasn't needed. Tried it on all of them (just in case). Yeah I've done exactly that now. They've given me a couple of extra things to try, but if not, they've said they'll gladly replace it, as it's quite sick :( – fantasitcalbeastly Nov 19 '14 at 11:20
3

Finally managed to fix this. So posting a solution in case anyone else has the same symptoms. There are two hidden settings that (according to Xbox support) can cause the issues I had been facing. I should note that I had Factory reset the night before trying this, so if it doesn't work first time, a reset may be required also. But all my game saves had been backed up to the cloud, so the only annoying part was game and app re-installation.

Clear Persistent Storage

Go to Settings -> Disc & Blu-ray -> Persistent Storage and hit "Clear Persistent Storage" - This is apparently a non-recyclable "temp" area for the OS. I'm guessing that its public writable, which would mean that there may well be various lock files in there that could get corrupted, thus cause issues.

Clear Alternate Mac Address

Not sure why this one would help, but I actioned the two tips combined, so placing here for completeness. Go to Settings -> Network -> Advanced Settings -> Alternate Mac Address -> Clear. (This may well force a restart)

Cycle Power

Cold reboot. Hold the power button down (on the system) for around 10 seconds. Then unplug EVERYTHING! Leave for around a minute. Then reboot with all your devices and peripherals as normal.

I was able to reboot just using the X button on a controller and it all came back to life. I'm very happy!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.