0

I'm having trouble trying to figure out how to get Stonesense working for the latest Dwarf Fortress.

I am using the latest LNP pack (40.16 r2).

Stonesense does not come with this package anymore for "technical reasons" as you can read on the bay12 forums.

I have Stonesense downloaded from their github here, but I can't find any where that tells me where to put these files in order to get them working!

  • Might those "technical reasons" be simply "it doesn't work anymore with the most recent version"? – Philipp Nov 20 '14 at 17:53
  • Thankfully, no. I'd imagine it's because the pack to seems to work on both Linux and Windows. stonesense used to be an exe. which obviously is for Windows and wouldn't work on Linux. – Panomosh Nov 20 '14 at 18:12
  • Your title no longer matches your question; you want to know where to put the files, not how to run it. – Frank Nov 20 '14 at 18:32
  • Sorry Frank, thanks for editing it but I'm leaving the title as is because it may not be down to where to put the files. It might require browsing to the directory using the dfhack console for example. I don't miss any potential answers! – Panomosh Nov 20 '14 at 18:50
1

So this is the result of outdated documentation and a timely bug.

First, Stonesense is now included with DFHack in the Starter Pack (previously known as the LNP). However from around versions 40.14-40.19 stonesense was broken due to changes in DF proper, so it wasn't shipped.

Updating to the latest DFHack / Starter Pack (for DF v0.40.19) will include stonesense.

  • Fantastic, thanks for answering :) been waiting ages to have a go with stonesense adventure mode – Panomosh Dec 10 '14 at 9:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.