3

It has been one month since this problem happened, I don't know how to fix it.

The problem

When I connect my power cord, the red Colour comes up as normal. But when I press it , it beeps one time (like normal) and it becomes green for 2 seconds and just goes off (there is no blinking issue, like many people have). I tried keeping it pressed, but nothing happens. It never passes the point of 2 seconds. But here's another thing that happens. When it goes off (blank) , if I press again on the power button it becomes red again, and when I press it becomes green with a beep for 2 second, and does the same process over again.

I tried cleaning it too, and I removed the back part and cleaned it carefully, didn't do any difference. Same results.

Any Idea how to to fix it ? Thanks.

My warranty period is over

  • 1
    It is dead Jim.. – user28015 Nov 28 '14 at 11:37
  • @NoneOfYourBusiness Hardware isn't just dead. Parts of it are, and those can be repaired. The question that remains is whether the repair is worth it. – No. 7892142 Nov 28 '14 at 12:33
  • Have you tried getting into contact with Sony? Perhaps they would be th e best option... – user92092 Nov 30 '14 at 9:11
  • I updated my answer to help you with your stuck disc. – Sentinel Gaming Nov 30 '14 at 17:22
1
+100

Removing the CD

Before you start, be sure that no CD's are still inside.
To remove them, there are instructions here.

For consistency, here are instructions for removing it on the PS3 FAT Model.

  • Turn off the PS3 system via the MAIN POWER switch while pressing and holding the eject button.
  • Turn the PS3 system on again via the MAIN POWER switch while still holding the eject button.
  • The PS3 system should now eject the disc.

Fixes

Before trying to fix your PS3 yourself, check to see if you have warranty. If you don't, don't stress. You should also try ringing Sony support or contacting them via email to question problems with them.
Should you run into a ditch or really just hate talking to Sony, then here are some fixes below for common and strange problems.

(Warning: Some fixes may result in data loss and may not fix your PS3 at all, so continue at your own risk)


Recovery Menu (Safe Mode)

Safe mode comes as valuable help as it can solve many problems by rebuilding or restoring systems if they malfunction. (Again, may not work for you, so do so at your own risk!)

To get into the Recovery Menu, you can read the page here, or follow exact instructions from it below:

  1. Turn off the PlayStation 3 by holding the Power button on the front of the unit till the Power light is red.

  2. Touch and hold the Power button (do not remove your finger from the button). You will hear the first beep, meaning the PlayStation 3 is powering on.

    Continue to hold the Power button and after about 5 seconds, you will hear a second beep, indicating the video reset.

    Continue to hold the Power button and after about another 5 seconds you will hear a third beep and the system will power off (Power light is red).

  3. Touch and hold the Power button (again, do not remove your finger from the button). As in Step 2, you will hear the first beep, again for the PlayStation 3 to power on.

    Continue to hold the Power button and after about 5 seconds, you will hear a second beep for video reset.

    Continue to hold the Power button and after about another 5 seconds you will hear a quick double beep. At that point release the Power button. If you succeeded in activating Safe Mode, you will see a message on the screen saying, "Connect the controller using a USB cable and then press the PS button."

    Connect a USB cable to the controller and the PlayStation 3 and press the PS button to enter Safe Mode.

    You will now see the Safe Mode menu.

  4. We recommend performing the safe mode options in the following order until one of the options works for you. If one of the options work, do not continue onto the other options.

    1. Restore Default Settings
    2. Restore File System
    3. Rebuild Database
    4. Restore PS3 System

Third Party Fixes

Third party fixes (i'm talking about videos to help you do this and that) tend to be quite low quality and aren't always reliable, so i'm not adding them.

They are all over the web and there would be too many to fit in here anyway.
If you cherish data and/or are worried about breaking your PS3 further, contact Sony or follow the Safe Mode instructions for your best chances.

Good luck!

  • (+1) What a long and well constructed answer! Thank you – The Artist Dec 5 '14 at 2:40
  • @TheArtist No problem. Thanks to you too again, and good luck! – user92092 Dec 5 '14 at 5:46
0

Your power supply might be the problem. Try replacing it. Here is a tutorial to do so :

  • 1
    This is a sheer guess. Based on the symptoms reported, I can almost certainly guarantee this is not the problem. – Frank Nov 28 '14 at 18:20
  • What'ta you think it is @Frank ? :O – user92092 Nov 28 '14 at 21:36
0

Your problem seems to be that dust might not be letting start up. Here's what I found that allowed my PS3 to work properly,

If the video gets taken down then what you need to do is carefully remove the top of the PS3's shell BUT remember where the screws go. Once you are at the inner workings of the system take a can of compressed air and start to dust the system carefully. Once you no longer see any dust start to put the shell back on, and your system should work. Hope you got it to work. Here is a way you can get your disc out

  • (+1) I could only remove one back part, I tried to remove the shell but there is a disc stuck inside, so I can't remove one nut :/ – The Artist Nov 30 '14 at 3:31
  • @TheArtist What!? You still have a game disc in there! You have to take it out first! xD – user92092 Dec 1 '14 at 20:27
  • @FinnRayment I tried to take it out :/ It doesn't come out :/ – The Artist Dec 2 '14 at 2:51
  • @TheArtist faq.en.playstation.com/app/answers/detail/a_id/7779/~/… Good luck! – user92092 Dec 2 '14 at 4:38
  • 1
    @SentinelGaming - Accepting an answer means the solution worked for the OP -who says that they tried both solutions above and neither fixed it (two comments above yours) – Robotnik Dec 3 '14 at 0:00

protected by Community Aug 30 '15 at 21:14

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.