4

This question already has an answer here:

I can browse the web fine, watch YouTube, listen to music, etc. But when I try to join ANY Minecraft server, as soon as I try to make a connection, I either:

Time out my connection

or:

Sit there waiting for it to load, then disconnect

On Minecraft, it says I have good ping to the server, but then I join it and I lag out as I stated above. I can connect to other servers on other games.. but not Minecraft. I have restarted my PC and my modem, still nothing.

What can I do to solve this issue ?

marked as duplicate by galacticninja, Joachim, Virusbomb, FoxMcCloud, Gigazelle Jul 11 at 18:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • There's some known connectivity issues with Minecraft 1.8 that I suspect might be a part of your problem. Unfortunately there's nothing you can really do about that other than wait for Mojang to figure out what they broke. It might be something else though, I'm not sure. – Unionhawk Nov 26 '14 at 5:23
  • I'm using 1.7.10.. but thanks for the info. – Skeesky_ Nov 26 '14 at 5:30
  • Oh, well in that case, I have no idea what's going on here. :/ – Unionhawk Nov 26 '14 at 5:33
  • Can you type out EXACTLY what the error is? (The Java part?) – user92092 Nov 26 '14 at 8:49
  • I have the exact same problem, except it happens uncommonly. aaaand nice edit, Shunwoo. – Louis Nov 26 '14 at 9:05
1

I have this problem as well, if it is a server hosted by someone that you know, see if they can reduce the Minecraftmulitplayercache (the number of chunks that a player is forced to load to join) this tends to help with server lag and can help improve your performance. The default is 441, which is quite a bit and you won't see all of the chunks that are downloaded if you are not using optifine or using a minecraft version 1.8 or above. You can ask the server admin to lower it to 169 (this is far less data that needs to be downloaded). While this might help I would also suggest downloading Netlimiter 4 it is free and will show you where your network is being used the most (this software will not affect the router itself, all it does is limits the size of packets that your computer pulls from the internet) you can limit how much of your bandwitdh that certain processes are using.

1

I sorted the list on most likely respective of the info you gave me. (Which is not a whole lot to work on, assuming you minecraft version is 100% legal and you are the only one using the account.)

First option is to see if you have the ports correctly filled in after the IP address. The correct syntax is 100.100.100.1:8080: the ip is 100.100.100.1 and the port is 8080. Note the ":" instead of the point.


If that doesn't solve the problem, the next thing to try is find a server that is not using your version, download that version (1.5.2 is very stable), then try and connect to it. (Don't open any single player worlds, not even the single player world selection screen.) If that works, it's a version problem: try to update or downgrade to one that works.


If that does not help, try deleting your .minecraft folder. Make sure you back the folder up and minecraft is closed first.

  • Mac: <user>/Library/Application Support/minecraft
  • Windows: Press Windows+R, type %appdata& and press Enter. Then locate .minecraft.

Many people have used this technique for similar problems without: eg. Internet connection, so the launcher could not re-download the folder. This is also the folder were world saves and texture-packs are stored so again, back it up first.

Then reopen the launcher, let it download the files and check if it works.


If that is not the case it might be that your servers are too heavy to run on your pc. What might help is setting you render distance to a lower number like 2, setting render mode to fast and turning vsync on.

Also you can make more RAM available to Minecraft to make it run faster. You can do this in the profile editor under Java settings (advanced). In JVM Arguments you will see that you can input how much ram you want Minecraft to be running on. In this box you fill in:

  • -Xmx2048M -Xms2048M for 2GB ram
  • -Xmx4096M -Xms4096M for 4GB ram
  • To add more, add 1024 to the numbers for an extra gigabyte. Example: 4096 (4GB) + 1024 = 5120 (5GB)

(Remember you need to make sure other programs can still run without Minecraft consuming all the RAM, so that might be a problem.)


Finally there might be a firewall issue... which would be odd because then Minecraft would tell you. Try to take down you firewall then log on the server then turn the firewall back on. If you get thrown off, you know what the problem is. If so you can ether tweak your firewall settings or disable it for good (be sure you know what you are doing here)


If that does not help try to set up a LAN world with another PC and try logging in there (make sure you are connected through LAN of course). If that does not work it might be your way of connecting to internet which does not allow you to go online on other games as well. Do you play other games online which are not an MMORG (MMORG's have one server only which is certified)? A good game to test this is Trackmania Nations Forever because it's free on Steam and has the same way of procesing servers. If this gives the same problem you should contact your ISP.

-1

If you're joining from a 1.8 client previously. Your render distance might be too high change it to below 16 chunks. This is 1.7's maximum chunk count since it was increased in 1.8 and it might have caused your timeouts.

  • 2
    This doesn't help the author in anyway, no information on howto fix it either. – user92092 Nov 26 '14 at 20:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.