2

Just started playing DF2014 (I played DF2012 a lot).

I have a new embark, and 2 peasants that won't do their labors. I have a mason with masonry enabled, who won't build a mason's workshop (he won't do anything but stand in the forest). I have a peasant with all hauling labors, wood cutting, and plant gathering enabled. I have trees designated to cut, wood and ore to be hauled, and plants designated to gather, but the peasant just idles.

What am I missing?

  • 3
    Do you have an axe? Can you path from the mason to the stone/wood you chose to make the mason's workshop out of? Is either dwarf stuck in a tree? Did you double-check that the labors are actually enabled? If you assign other dwarves to the labors, do they get done? Is it possible you dug into the earth and accidentally cut off access somewhere by removing stairs/ramps? Unlikely, but do you have any dwarves burrowed somewhere? This is the kind of question that calls out for some screenshots. – Andrew Larned Dec 2 '14 at 22:32
  • Or, better still, post your save. – Studoku- Reinstate Monica Dec 2 '14 at 23:15
  • If I assign another then things get done, just those 2 are always idle no matter what. None of the other issues there are applicable, I'll research this 'stuck in a tree' tomfoolery and post a save if that isn't the problem. – nexus_2006 Dec 8 '14 at 0:13
  • So the 2 dwarfs in question climbed over the river via the trees, which were cut down in the mean time, so they could not path back. Bridge built, problem solved. – nexus_2006 Dec 8 '14 at 2:38
  • @nexus_2006 Could you please close the question since your issue is resolved? Thanks! – Casey Dec 10 '14 at 7:05
0

Thanks to AndrewLarned I figured out it was a pathing issue. In 40.x dwarfs now climb trees. In my case the dwarfs climbed over the river, and then enough trees were cut that they couldn't path back.

Bridge built, problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.