2

1 & 2: I'm using the Tekkit and Attack of the B-Team modpacks from the Technic Launcher. Their current Minecraft versions are both 1.6.4 I think.

3: The following log is from my "logs" folder when I search %appdata% and open the .technic folder - from today when I tried to launch Tekkit: http://paste.ubuntu.com/9374783/

The end part where the error occurs:

[B#439] 2014/12/03 13:53:41 [INFO]  2014-12-03 13:53:41 [WARNING] [ForgeModLoader] The coremod codechicken.core.launch.DepLoader does not have a MCVersion annotation, it may cause issues with this version of Minecraft
[B#439] 2014/12/03 13:53:41 [INFO]  2014-12-03 13:53:41 [INFO] [ForgeModLoader] Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[B#439] 2014/12/03 13:53:41 [INFO]  2014-12-03 13:53:41 [INFO] [ForgeModLoader] Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
[B#439] 2014/12/03 13:53:41 [INFO]  2014-12-03 13:53:41 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[B#439] 2014/12/03 13:53:41 [INFO]  2014-12-03 13:53:41 [SEVERE] [ForgeModLoader] Unable to launch
[B#439] 2014/12/03 13:53:41 [INFO]  java.util.ConcurrentModificationException
[B#439] 2014/12/03 13:53:41 [INFO]      at java.util.ArrayList$Itr.checkForComodification(Unknown Source)
[B#439] 2014/12/03 13:53:41 [INFO]      at java.util.ArrayList$Itr.remove(Unknown Source)
[B#439] 2014/12/03 13:53:41 [INFO]      at net.minecraft.launchwrapper.Launch.launch(Launch.java:114)
[B#439] 2014/12/03 13:53:41 [INFO]      at net.minecraft.launchwrapper.Launch.main(Launch.java:27)
[B#439] 2014/12/03 13:53:42 [INFO]  Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
[B#439] 2014/12/03 13:54:21 [INFO] Maximum usable memory detected: 3978 mb
[B#439] 2014/12/03 14:18:59 [INFO] ------------------------------------------
[B#439] 2014/12/03 14:18:59 [INFO] Technic Launcher is starting....
[B#439] 2014/12/03 14:18:59 [INFO] Launcher Build: 439
[B#439] 2014/12/03 14:18:59 [INFO] ------------ Startup Parameters ------------
[B#439] 2014/12/03 14:18:59 [INFO] --------- End of Startup Parameters ---------
[B#439] 2014/12/03 14:18:59 [INFO] Analytics Response [runLauncher]: 200
[B#439] 2014/12/03 14:19:01 [INFO] {"accessToken":"5c559bb7e0ed418c94d8cd60ef77d77a","clientToken":"d71edf1b-160b-43d9-9f21-2e7a72a7eec1","selectedProfile":{"id":"f0be942e14da46c79ddf4a9eabf2269d","name":"QUOFFEE"}}
[B#439] 2014/12/03 14:19:01 [INFO] Launcher took: 2102ms to start
[B#439] 2014/12/03 14:19:01 [INFO] Pack: tekkitmain Image Download Worker Calculated MD5: bccfd794ff80c03dae9424a0cc0eda5f Required MD5: f39ae618809383451f6832e4d2a738fe
[B#439] 2014/12/03 14:19:01 [INFO] Starting download of http://cdn.technicpack.net/resources/tekkitmain/background.png?1410213214, with 3 tries remaining
[B#439] 2014/12/03 14:19:01 [INFO] Pack: tekkitmain Image Download Worker Calculated MD5: f9a822f3a2997db95806f0175da24e32 Required MD5: 1dd87c03268a7144411bb8cbe8bf7326
[B#439] 2014/12/03 14:19:01 [INFO] Starting download of http://cdn.technicpack.net/resources/tekkitmain/icon.png?1410213214, with 3 tries remaining
[B#439] 2014/12/03 14:19:01 [INFO] Pack: hexxit Image Download Worker Calculated MD5: 418def033519963168abd7a0d2189d36 Required MD5: 1426f5b19df42eab2cabbaa34823c8c9
[B#439] 2014/12/03 14:19:01 [INFO] Starting download of http://cdn.technicpack.net/resources/hexxit/logo.png?1414112755, with 3 tries remaining
[B#439] 2014/12/03 14:19:42 [INFO] Maximum usable memory detected: 3978 mb

4: Computer specs... All I know is it's a 64-bit Windows 7. Where can I find other stuff?

5: AotBT kept running out of memory and I found out that to solve this, I could allocate more RAM using the gear at the top-right of the Technic Launcher. However, I had to get 64-bit Java to add more than just 1 GB. I downloaded JRE 8 release 25 to solve this, and immediately allocated 2 GB instead of 1. Ever since then, the launcher has disappeared after hitting "Play" as usual, but it has reappeared a few seconds after and no game is launched. The exact same thing happens with Tekkit.

6: I tried uninstalling the 32-bit Java 7 that I previously used, but that didn't work. The same issue keeps happening. Being not all that good at fixing this stuff, I don't know what else to do.

I'd like to know how to fix this issue so I can play these modpacks, as they are my favorite packs in the Technic Launcher.

closed as off-topic by greg-449, dly, Joachim, Tim S., Virusbomb Jun 27 at 14:06

  • This question does not appear to be about videogames or videogame consoles within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Unfortunately, in order for us to be able to help you, we're going to need a crash log. We literally can't help until you provide one. It's not that we won't or don't want to, but can't. There's a certain level of information required from your end before we can help you. – Frank Dec 3 '14 at 20:12
  • Well yeah. :P What I was irritated at was that people on the other forum straight-up refused to help. They didn't even ask for one. Posts without one just get deleted or locked... Thank you for being reasonable with this! How does one get a crash report? (: -- Edit -- I forgot to ask in the original post how to get a crash report if one is needed. That is my fault. D: – Ryan Courtney Dec 3 '14 at 20:14
  • To my knowledge, it's supposed to reside in the folder where Minecraft is. Either way, please read our, How do I ask a good Minecraft crash question, and provide the information it asks for. That will give you your best chance of us being able to help you resolve your problem. – Frank Dec 3 '14 at 20:17
  • 1
    Done! I hope it's enough to help... – Ryan Courtney Dec 3 '14 at 20:39
  • 3
    I'm voting to close this question as off-topic because we don't provide tech support for modded Minecraft. – dly Jun 27 at 6:41
1

I'm assuming you're using Java 8. According to this Technic Platform news post, Java 8 Update 20 and later are incompatible with Forge Modloader, which is at the heart of the Technic Platform modpacks. They recommend downgrading to the last version of Java 7, which you can get here.

-1

What's wrong?

The Technic launcher fails to get to the point where it starts loading Minecraft (actually open the minecraft.jar.

Possible Solutions

  1. Run the modpack on a seperate launcher (ie. MagicLauncher or MultiMC)
  2. Check if your Java has sufficient read-write permissions.
  3. Make sure you have allocated enough memory.
    (PermGen space and allocated RAM are two different things. One is used to start the game, the other is to run it)
  4. Make sure you have enough hard drive memory.
  5. Use Java 7 instead of Java 8.

Note on #3: You can't define the PermGen space in the Technic Launcher only the allocated RAM.

  • I can't paste the log itself because of the character limit. ): I changed the source of the log paste from Pastebin to Ubuntu, so I hope that works. Java 7 was what prevented AotBT from running, since it couldn't allocate enough RAM to the game to run it. It would run out of memory whenever making a new world. I installed Java 8 because I read it lets you allocate over 1 GB, which was Java 7's limit. Going back to Java 7 wouldn't help. ): When the launcher disappears to launch Minecraft, it just reappears a couple seconds later. – Ryan Courtney Dec 5 '14 at 0:56
  • After checking the log (if you haven't already and if you can see it now), if you find that the problem is still what you say, could you explain to me how to do each of those four solutions? – Ryan Courtney Dec 5 '14 at 0:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.