1

I am attempting to record a video ( 720px ) at 30 fps. I have recorded videos like this before without any issue, typically getting 60+ fps while recording. Today however I'm getting 7-8 fps. I have tried to restart my computer. I have even tried recording at 240px and at 10 fps video, and I still get 7-8 fps.

I check my video file and find it to have 1.28 Gb/s data-rate. If my math is correct, a 720px video should be:

1280x720 = 921600 pixels Each pixel is RGB so that's 3 bytes per pixel = 2,764,800 bytes (2.7 MB) 30 FPS = 2.7x30 = 82,944,000 MB/s 8 bits per byte so 82 Megabytes is 663.552 Megabits/s. So DxTory is writing 2x the data for the video.

When I recorded at 240px at 10 fps, the data-rate was the same, even though that would only be 73.612 Megabits/s

The result is the same regardless of the video Codec I select. Recording to rawcap instead of AVI gives me up to 18 fps instead of 8, however the same issue exists.

I can post specific information (like environment data) if requested.

Does anyone have any idea why/how this could be occurring?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.