How do I stop bots from attacking?

I accidentally typed in nav_generate so I don't know if this affected anything but if yes, how do I reverse it?

  • Why do you have bots if you don't want them to participate? You'll need to explain what you're trying to do. – Toomai Dec 4 '14 at 15:33
  • @Toomai There's plenty of reason to want non-attacking bots for experimentation or target practice. – jw013 Dec 4 '14 at 16:37
  • 1
    Knowing exactly what the reason is will help determine what answer to give. – Toomai Dec 4 '14 at 16:56

By default, Puppet Bots will remain motionless, but will attack if they can see you.

bot -team <teamname/number> -class <classname> -name <botname>

You can input other commands to force these bots to take certain actions. In particular, you can use

bot_forceattack 0
bot_forceattack2 0

to prevent the bot from attacking and

bot_dontmove 1

to prevent the bot from moving.

| improve this answer | |
  • but the bots I spawn with tf_bot_add always attack me,is there a command to stop them from attacking me? – user93872 Dec 7 '14 at 13:54
  • @user93872 I've updated the answer to include an option to prevent attacking. – Austin Mohr Dec 8 '14 at 2:55

You'll need to enable cheats with sv_cheats 1, but if you type nb_blind 1 this freezes the bots and they won't shoot or move.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.