0

When using command blocks on an Aternos.org (free online server hosting) server, target selectors (@a, @p, etc.) don't work.

For example, /tp BillBodkin x y z, works fine but /tp @p x y z doesn't work and the command block output returns -

Any idea why?

2
  • 4
    Are you running both commands in a command block? What happens when you run them from chat?
    – MBraedley
    Dec 6, 2014 at 14:00
  • Do you have any plugin ?
    – Seblor
    May 28, 2015 at 10:28

2 Answers 2

1

I have an Aternos server and command blocks can be a problem, here is a list of things you could try:

  • Make sure Command Blocks are turned on
  • Make sure that your internet connection is working fine
  • Make sure there are no spelling errors or typos
  • Restart Server as many times as needed to make it work

Important: All the above suggestions only work in 1.8. Most 1.8 snapshots and pre-releases are very buggy. Use a version of Minecraft that is not a snapshot or a pre-release (make sure it is a fully released minecraft version).

0

This once happened to me, while having a pressure plate on glass and it is having the Redstone (or energy) passing to the command block. What was strange was that it gave "-". What I tried (And for some reason worked) was to directly put the pressure plate on the command block. So, my idea is that it needs a direct source of energy (or Redstone).

1
  • My first setup was having the pressure plate, below it the glass, and then below it the command block. In the second one (the one that worked) it was the pressure plate and the below it the command block. (For Some Understanding Help) Jan 8, 2022 at 1:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .