4

I am having problems with Minecraft resource packs. I decided to make adventure maps with custom music using the resource packs. After spending some time making the files, everything did work, and the audio did play correctly. But, what I noticed was that the Minecraft default music would still play over top of my music when I played it. I tried to go to the settings and turn it off, but if you turn the "Music" setting down under the Music & Sounds option, then it will turn off both my music, and the Minecraft music. If I turn the music option back on, and play the audio, it will play, and then eventually another Minecraft song will play over top of it. Is there any way I can make just the Minecraft songs stop playing when I play my music?

  • Do you play your music with commandblocks? – Lars Dec 12 '14 at 14:18
  • @Lars I beleive he is saying this is background music installed in his resource pack. – Ben Dec 12 '14 at 16:55
1

You have to override all of the different music files of minecraft, which are
music/game/calm1-3, music/game/hal1-4, music/game/nuance1-2 and music/game/piano1-3

Otherwise the non-overridden songs will still play.

Minecraft will play one of these songs every 5 minutes, which means that two songs can never overlap, however, if you are using /playsound for this, then minecraft will also play those songs at random intervals, causing two songs to overlap

minecraft wiki on sounds: http://minecraft.gamepedia.com/Sounds.json

  • Yes, I am using command blocks to play the music with the /playsound command. My question is, how do I override the minecraft music files? – user84344 Dec 14 '14 at 19:10
  • 1
    just make a few new files in the assets\minecraft\sounds\music\game called calm1 ..calm2 ..calm3 ..hal1 ..hal2 ect, just having the file in there overrides the music so just put some empty files. For the entire folder structure goto minecraft.gamepedia.com/Resource_pack --EDIT these files have to be in your recourcepack, not in your actual minecraft files – lennartVH01 Dec 14 '14 at 20:22
  • I do not know what is happening, but all of the folders in my resource pack are assets/minecraft/sounds/music, and the files in the music file are calm1-3, hal1-4, nuance1-2, piano1-3, and my song file, just as you said. These files are all just supposed to be normal folders with nothing in them right? Because minecraft will still play songs over it. – user84344 Dec 15 '14 at 0:21
  • In your recourcepack, make the files calm1-3 hal1-4 ect just empty files, if a file just exists then when minecraft tries to play it's calm1-3 hal1-4 ect songs, then it will look in the recourcepack first and it will therefore play the "empty" music file, which basically means no music – lennartVH01 Dec 15 '14 at 11:58
0

If you want only your music to play: Turn off Music in "Options" and keep the master volume up. I did this on a minecraft server with a recourcepack and it worked.

  • Except that he has his custom sounds in the music folder, which uses the music volume. He could move them out to the root sounds folder and do what you are saying, but then anyone wanting to turn off the music will have to use the master volume and turn off all sounds. – jb11 Jan 14 '15 at 0:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.