I have Windows 7 64-bit and I'm trying to run C&C Generals Zero Hour on it. Generals itself works fine but Zero Hour just quits after the splash screen.

I have the latest version (1.04) and made sure I have latest nVidia drivers etc. I have tried all the ini file tricks and running it in XP compatibility mode that those don't seem to work.

I've also tried the following:

  • Install DirectX 9.0C
  • Run as administrator
  • Set compatibility to Windows XP SP2/SP3
  • Change the options.ini for Zero Hour, this is in a different folder than the normal generals options.ini.

I haven't tried the XP compatibility mode yet, which would basically virtualize an XP instance to run the game.

Some things to try if you haven't already (according to: http://forums.cncnz.com/index.php?showtopic=12319)

  • Install DirectX 9.0C
  • Run as administrator
  • Set compatibility to Windows XP SP3
  • Change the options.ini for Zero Hour, this is in a different folder than the normal generals options.ini.
  • 1
    I've tried all of that already. – lhahne Jul 15 '10 at 12:52

I guess that if you have a good machine you could set up a virtual machine with XP and try it from there... it will have a perf hit.. but generals is a little old, so it might be ok..

  • I think I'll try the XP compatibility mode next. – lhahne Jul 16 '10 at 7:26

You can also try XP mode inside of windows 7

It's a free download from Microsoft

Download Windows XP mode for Windows 7

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.