I have Windows 7 64-bit, and I'm trying to run Command & Conquer: Generals – Zero Hour on it. Generals itself works fine, but Zero Hour just quits after the splash screen.

I have the latest version (1.04) and made sure I have the latest Nvidia drivers, etc. I have tried all the .INI file tricks and running it in XP compatibility mode, but those don't seem to work.

I've also tried the following:

  • Install DirectX 9.0c
  • Run as administrator
  • Set compatibility to Windows XP SP2/SP3
  • Change the options.ini for Zero Hour; this is in a different folder than the normal Generals options.ini

6 Answers 6


The reason that this game no longer works is outlined by the other answer and this other question on Arqade. Basically there was a security hole in Windows 7 and 8 that Microsoft patched that makes certain write protection not work anymore. There is a simpler and safer solution to the problem than the one outlined in the other answer though (note that there is no workaround for Windows 10). First, open a command prompt as an administrator:

Windows button -> cmd.exe -> right-click -> Run as administrator

Run this command (with the exact spaces) to reenable the driver's service:

sc config secdrv start= demand

You should get a [SC] ChangeServiceConfig SUCCESS message. Then run this command to start the service:

sc start secdrv

Then open the game and it should work! You'll have to start the service every time you want to run this or any other CD-based game with SafeDisc or SecuROM, and you'll probably want to stop it when you're done to reduce security risks.

  • 2
    This definitely brought me closer to a solution than anything else I've seen before, the game launched but a serious error occurred afterwards. I think this solution ought to work out for most people though, and might just require doing the things others have suggested too.
    – Etzel
    Commented Dec 15, 2015 at 22:23
  • 2
    worked for me, windows 8.1 64 bit c&c general with daemon tools lite Commented Jan 14, 2016 at 15:44

Some things to try if you haven't already (according to: http://forums.cncnz.com/index.php?showtopic=12319)

  • Install DirectX 9.0C
  • Run as administrator
  • Set compatibility to Windows XP SP3
  • Change the options.ini for Zero Hour, this is in a different folder than the normal generals options.ini.
  • 1
    I've tried all of that already.
    – lhahne
    Commented Jul 15, 2010 at 12:52

I guess that if you have a good machine you could set up a virtual machine with XP and try it from there... it will have a perf hit.. but generals is a little old, so it might be ok..

  • I think I'll try the XP compatibility mode next.
    – lhahne
    Commented Jul 16, 2010 at 7:26

Following the instructions on forums.cncnz.com worked for me. I already had the latest drivers and I installed C&C Generals and Zero Hour. Then (these are I think the most important parts):

  1. Try to run C&C. It will not work but it will create this directory: C:\Users\<your user name>\Documents\Command and Conquer Generals Zero Hour Data.
  2. In this directory, create an empty file called options.ini.
  3. Copy these contents to the file:
AntiAliasing = 1
BuildingOcclusion = yes
CampaignDifficulty = 0
DynamicLOD = yes
ExtraAnimations = yes
GameSpyIPAddress =
Gamma = 50
HeatEffects = yes
IPAddress =
IdealStaticGameLOD = Low
LanguageFilter = false
MaxParticleCount = 5000
MusicVolume = 55
Resolution = 1366 768
Retaliation = yes
SFX3DVolume = 79
SFXVolume = 71
ScrollFactor = 60
SendDelay = no
ShowSoftWaterEdge = yes
ShowTrees = yes
StaticGameLOD = Custom
TextureReduction = 0
UseAlternateMouse = yes
UseCloudMap = yes
UseDoubleClickAttackMove = no
UseLightMap = yes
UseShadowDecals = yes
UseShadowVolumes = yes
VoiceVolume = 70
  1. In Windows Explorer, go to C:\Program Files (x86)\EA Games\Command & Conquer Generals Zero Hour.
  2. Right-click on generals.exe. Select Properties.
  3. On the Compatibility tab, check Run this program in compatibility mode for and in the drop down select Windows XP (Service Pack 3).
  4. On the same tab, under Privilege Level check the Run this program as administrator check box.
  5. Press OK and then run the program.

So far this crashed once (with a "serious error" when I changed the settings in game) - apart from that it has worked fine.


I have Windows 7 64-bit as well. Generals did work on my computer at some point but no longer worked for a while. I did try all the fixes you mentioned, and I eventually found out that my problem was caused by a Windows update, specifically, Update KB3086255. Here's a link to show you how to uninstall the aforementioned update:

  • @Texenox What relevant information could he possible have added? how to remove a windows update from your update history?
    – childe
    Commented Oct 27, 2015 at 22:36
  • @Texenox This question is not "How to uninstall a Windows update", though. They can look that up somewhere else.
    – Nyerguds
    Commented Feb 7, 2016 at 23:56

You can also try XP mode inside of windows 7

It's a free download from Microsoft

Download Windows XP mode for Windows 7

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .