Sometimes, when I try to install a newly-released game demo on Steam, clicking the "Download Demo" button in the store page, from the built-in Steam browser, just does nothing - the only thing which is happening is the the mouse cursor momentarily changes from a link pointer to a regular arrow.

If I go to the store page from outside Steam and click the "download demo" button, it correctly prompts me to open Steam - but then it does nothing as well.

This has happened for me more than once, with more than one demo; but other demos download, install and run just fine. Can anyone provide a solution?

OS is Windows 7 64 bit.

  • Have you tried copy pasting the link url (e.g., steam://install/99870/) and running it from Win-R? – badp Apr 9 '11 at 10:02
  • @failbadp tried it now, doesn't do anything (except for focusing on the Steam window). – Oak Apr 9 '11 at 10:04

It happened also to me more than one time, with just released demo. Usually I wait the next day and it works.

I imagine that the problem could be caused by the fact that demo files are not yet globally distributed through all Steam server network.

I never tried, I will do next time, but maybe changing the download region from Steam -> Settings -> Download and Cloud could help.

  • I've tried changing the region to various other places, it didn't work. I'll wait until tomorrow and see if it can be downloaded. – Oak Apr 9 '11 at 10:07
  • Which demo are you trying to download, if i can ask? – Drake Apr 9 '11 at 12:25
  • doesn't really matter - as you wrote yourself it also happened to me with other demos, but yes, it only happened with newly-released one. – Oak Apr 9 '11 at 13:05
  • @Oak I suspect that the game, in the most recent case, was Anomaly: Warzone Earth. I had problems too to download it during the initial days, but now it seems working. Do you have news? – Drake Apr 13 '11 at 22:43
  • it is indeed the game, but that was a special case, as there was a global problem with the demo - as admitted by the game studios. However, regarding other demos, I still think your answer is accurate - so I'm accepting it; this demo was an exception, I believe. – Oak Apr 14 '11 at 5:09

I experienced this issue with Steam on Linux. Opening the Store page in a browser, clicking “Download Demo” there, and allowing xdg-open to open it with Steam, did trigger a download popup for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.