1

So I have just bought minecraft from minecraft.net. I downloaded the installer "minecraftinstaller.msi" and installed it. Then I tried to open the minecraft launcher, but when i did that a window opened with the text "unknown error". I have no idea why this happens. I have tried to remove java and install it again but it did not work. I have a Windows Vista with 3GB RAM. Is that not enough to run minecraft? Have I wasted my money?

  • 1
    Vista with 3GB RAM should run Minecraft, although it's not exactly a gaming computer. Are there any other error messages (like an error code or something)? – FlyingPiMonster Dec 25 '14 at 15:33
  • No none. But I have downloaded the old launcher and now it works, still haven;t figured out about the new launcher though – Baes Dec 26 '14 at 13:40
  • are you running any other version e.g. tekkit classic – user96634 Dec 26 '14 at 16:13
  • I think so, not sure actually. How do I know that? – Baes Dec 26 '14 at 22:05
  • Have you tried to erase .minecraft folder in ÷APPDATA÷ ? – kiwixz Dec 27 '14 at 0:06
0

The Minecraft installer is a new feature. It was introduced to remove the hassle of manually setting up Minecraft, but it may have some quirks that make it stop working on certain machines.

Nevertheless, there is an alternative way to install Minecraft:

  • Head over to the Minecraft download site and download the file Minecraft.exe
  • Open the file browser and navigate to your personal directory
  • Create a new directory called Minecraft and place the downloaded file Minecraft.exe in there
  • Rightclick the Minecraft.exe and select create shortcut. That creates a shortcut that you can drag onto your desktop.
  • Double click the shortcut to start Minecraft

I hope that works for you! If not, please leave a comment with further details.

  • Have done exactly what you said, but I still get a window with the unknown error. I noticed that eversince i got a new file in the directory called "nativelog". This is what it says. – Baes Dec 28 '14 at 12:25
  • Failed to download manifest Failed to start application .\runtime\jre-x32\\bin\java.exe -cp "game\launcher.jar" net.minecraft.launcher.Main – Baes Dec 28 '14 at 12:26
  • That probably means there is something wrong with the bundled Java version. Try downloading the file Minecraft.exe in the section Minecraft for Windows (alternative). – Lars Dec 28 '14 at 16:19
  • Thanks man! It works just fine now. Really appreciated the time and effort you put into solving this problem. Have a nice day! – Baes Dec 29 '14 at 8:54

protected by Community Dec 27 '14 at 16:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.