0

I have a new laptop- rather than installing my bajillions of mods onto it I just copied and pasted my .minecraft folder. It works fine on my old laptop, but won't work on my new one-- I press play and the launcher closes, then nothing happens. The task manager shows javaw.exe appearing for a couple seconds and then suddenly dissappearing. Minecraft works fine with any other version besides forge. I'm running forge 1.6.4. Any help?

Note: both computers are running Windows 8.

Okay, so I just discovered something important. Rather than copying my minecraft.jar, I simply installed forge- and yet the same error happens with no mods installed. Here's the error report:

2014-12-28 10:00:01 [INFO] [ForgeModLoader] Forge Mod Loader version 6.4.49.965 for Minecraft 1.6.4 loading
2014-12-28 10:00:01 [INFO] [ForgeModLoader] Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_25, running on Windows 8.1:amd64:6.3, installed at C:\Users\Kenemon\Desktop\runtime\jre-x64\1.8.0_25
2014-12-28 10:00:01 [FINE] [ForgeModLoader] Java classpath at launch is C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\net\minecraftforge\minecraftforge\9.11.1.965\minecraftforge-9.11.1.965.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\net\minecraft\launchwrapper\1.8\launchwrapper-1.8.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\org\ow2\asm\asm-all\4.1\asm-all-4.1.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\org\scala-lang\scala-library\2.10.2\scala-library-2.10.2.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\org\scala-lang\scala-compiler\2.10.2\scala-compiler-2.10.2.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\lzma\lzma\0.0.1\lzma-0.0.1.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\net\sf\jopt-simple\jopt-simple\4.5\jopt-simple-4.5.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\com\paulscode\codecjorbis\20101023\codecjorbis-20101023.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\com\paulscode\codecwav\20101023\codecwav-20101023.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\com\paulscode\libraryjavasound\20101123\libraryjavasound-20101123.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\com\paulscode\librarylwjglopenal\20100824\librarylwjglopenal-20100824.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\com\paulscode\soundsystem\20120107\soundsystem-20120107.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\argo\argo\2.25_fixed\argo-2.25_fixed.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\org\bouncycastle\bcprov-jdk15on\1.47\bcprov-jdk15on-1.47.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\com\google\guava\guava\14.0\guava-14.0.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\org\apache\commons\commons-lang3\3.1\commons-lang3-3.1.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\commons-io\commons-io\2.4\commons-io-2.4.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\net\java\jinput\jinput\2.0.5\jinput-2.0.5.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\net\java\jutils\jutils\1.0.0\jutils-1.0.0.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\com\google\code\gson\gson\2.2.2\gson-2.2.2.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\org\lwjgl\lwjgl\lwjgl\2.9.0\lwjgl-2.9.0.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\libraries\org\lwjgl\lwjgl\lwjgl_util\2.9.0\lwjgl_util-2.9.0.jar;C:\Users\Kenemon\AppData\Roaming\.minecraft\versions\1.6.4-Forge9.11.1.965\1.6.4-Forge9.11.1.965.jar
2014-12-28 10:00:01 [FINE] [ForgeModLoader] Java library path at launch is C:\Users\Kenemon\AppData\Roaming\.minecraft\versions\1.6.4-Forge9.11.1.965\1.6.4-Forge9.11.1.965-natives-121023374937945
2014-12-28 10:00:01 [FINE] [ForgeModLoader] Enabling runtime deobfuscation
2014-12-28 10:00:01 [FINE] [ForgeModLoader] Instantiating coremod class FMLCorePlugin
2014-12-28 10:00:01 [FINE] [ForgeModLoader] Enqueued coremod FMLCorePlugin
2014-12-28 10:00:01 [FINE] [ForgeModLoader] Instantiating coremod class FMLForgePlugin
2014-12-28 10:00:01 [FINE] [ForgeModLoader] Enqueued coremod FMLForgePlugin
2014-12-28 10:00:01 [FINE] [ForgeModLoader] All fundamental core mods are successfully located
2014-12-28 10:00:01 [FINE] [ForgeModLoader] Discovering coremods
2014-12-28 10:00:01 [INFO] [ForgeModLoader] Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
2014-12-28 10:00:01 [INFO] [ForgeModLoader] Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
2014-12-28 10:00:02 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
2014-12-28 10:00:02 [SEVERE] [ForgeModLoader] Unable to launch
java.util.ConcurrentModificationException
    at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:901)
    at java.util.ArrayList$Itr.remove(ArrayList.java:865)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:114)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:27)

closed as off-topic by Joachim, dly, Gigazelle, Schism, Tim S. Jul 7 at 1:05

  • This question does not appear to be about videogames or videogame consoles within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Is the same java version as on the old system installed? – Gerret Dec 28 '14 at 0:45
  • 5
    I'm voting to close this question as off-topic because it is about support for a modded version of Minecraft. – Joachim Jul 6 at 16:38
  • 1
    Despite there already being an answer, I'm afraid that off-topic questions are still off-topic. – Gigazelle Jul 6 at 21:59
  • 1
    @bearb001 Questions must stand on their own. Voting to leave open because you disagree with the blanket ban on modded Minecraft tech support is your prerogative, but you should not be voting to leave open just because there's an answer. – Schism Jul 6 at 22:06
  • 1
    @bearb001 We tried allowing modded minecraft tech support questions to be on-topic a while back, and it was a disaster. Compared to any other "modded game support" question, it was easily 1000 to 1 for modded minecraft, and there are always so many possibilities of issues with mods and relatively custom configurations they were near impossible to troubleshoot. There is plenty of history there, and the decision was discussed in great detail for a long time. – Tim S. Jul 7 at 1:04
3

Here is your culprit:

2014-12-28 10:00:02 [SEVERE] [ForgeModLoader] Unable to launch
java.util.ConcurrentModificationException
    at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:901)
    at java.util.ArrayList$Itr.remove(ArrayList.java:865)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:114)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:27)

A change introduced in Java 8u20 has been giving Forge trouble. This was recently fixed in Forge, so updating Forge will solve this for you.

If you have mods that depend on older versions of Forge, however, you'll have to get a bit dirty. There are two known ways around the issue:

  1. Patch your local Forge version. FyberOptic on minecraftforum.net has files and instructions on how to do this. In short, you take a patched version of the offending code, plug it into your local library, and that should take care of it.

  2. Install Java 7. You can keep several Java installations on the same machine. See "Minecraft Forge 1.7.10 will not start" for instructions on how to run Forge on the old Java.

    Word of warning, though: official support for Java 7 will be discontinued after April 2015.

Not the answer you're looking for? Browse other questions tagged or ask your own question.