2

I am using Snes9x to play Nintendo games on my Mac mini. I have connected a wired USB PS3 controller and I have been successful configuring it with the emulator. However, I am experiencing a noticeable latency (time lapse) between the buttons being pressed and the actions happening in the game. The result is such that a jump in Mario brothers happens too late, and I die by falling into a pit or running into an enemy. It is really annoying, and it makes the games virtually unplayable. (pun intended) I wish there was a setting to adjust the timing so that I could compensate for the timing. Has anyone experienced this problem and come up with a solution? Does anyone know of another successful configuration

  • different emulator
  • controller
  • computer, etc...?
2
  • 1
    ...pun intended..? Oh! "Virtually" slaps knee
    – Ben
    Commented Dec 29, 2014 at 1:34
  • Does frameskip or a "use raw input" setting do anything?
    – oldmud0
    Commented Dec 29, 2014 at 2:47

2 Answers 2

2

The list of possible sources of lag, in decreasing probability order:

  • HDTV. You are probably using one with your Mac mini. Put it into game mode if possible. Disable fancy options named "intelligent frame creation" or something like that. Connect a PC monitor instead, or, even better, CRT, if you still can find one. The amount of lag varies wildly between HDTV models, from negligible to unplayable. Home theatre video processors also add lag.
  • Emulator & video card configuration if the emulator is using 3D acceleration features for some reason. Try using simpler video configuration, disable filters etc. Try different emulators. They do add lag, some less, some more.
  • wireless controllers (some have virtually no lag, some add a lot)
  • wired controllers and keyboard. Unless something went really really wrong, the amount of lag they add is tiny.
  • can't say anything about the operating system. While I'm writing this from a mac I only use emulators on windows and on portable devices.
1

I also noticed a lot of latency with a bluetooth SNES controller and Snes9x 1.60. It was fixed by checking this setting:

Video -> Display Configuration -> Reduce Input Lag

If that doesn't work you can also try turning off graphics scalers and other filters.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .