10

I'm trying to connect to a friend's Minecraft server, but I'm not able to do so. We've double-checked the usual culprits brought up in most Minecraft server tutorials, but we're still not having any luck.

This is our specific situation:

I'm on a Mac OSX machine and want to connect to my friend's server. He's running the server and a client at the same time on his Windows machine. We're both on the same local network. He's able to start and connect to his server. Whenever I try to connect to his server using our external IP address, however, I get the following error:

enter image description here

This is what my log looks like when I try to connect to his server from our external IP address:

[16:45:46] [Client thread/INFO]: Connecting to [IP address], 25565
[16:45:46] [Server Connector #1/ERROR]: Couldn't connect to server
java.net.ConnectException: Connection refused: /[IP address]:25565
    at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method) ~[?:1.6.0_65]
    at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:599) ~[?:1.6.0_65]
    at io.netty.channel.socket.nio.NioSocketChannel.doFinishConnect(NioSocketChannel.java:208) ~[netty-all-4.0.23.Final.jar:4.0.23.Final]
    at io.netty.channel.nio.AbstractNioChannel$AbstractNioUnsafe.finishConnect(AbstractNioChannel.java:287) ~[netty-all-4.0.23.Final.jar:4.0.23.Final]
    at io.netty.channel.nio.NioEventLoop.processSelectedKey(NioEventLoop.java:528) ~[netty-all-4.0.23.Final.jar:4.0.23.Final]
    at io.netty.channel.nio.NioEventLoop.processSelectedKeysOptimized(NioEventLoop.java:468) ~[netty-all-4.0.23.Final.jar:4.0.23.Final]
    at io.netty.channel.nio.NioEventLoop.processSelectedKeys(NioEventLoop.java:382) ~[netty-all-4.0.23.Final.jar:4.0.23.Final]
    at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:354) ~[netty-all-4.0.23.Final.jar:4.0.23.Final]
    at io.netty.util.concurrent.SingleThreadEventExecutor$2.run(SingleThreadEventExecutor.java:116) ~[netty-all-4.0.23.Final.jar:4.0.23.Final]
    at java.lang.Thread.run(Thread.java:695) ~[?:1.6.0_65]

When I try to connect to his server by using his internal IP address for the server, I get this error:

enter image description here

And this is in my log file:

[13:52:08] [Client thread/INFO]: Connecting to 192.168.2.16, 25565
[13:52:38] [Server Connector #1/ERROR]: Couldn't connect to server
io.netty.channel.ConnectTimeoutException: connection timed out: /192.168.2.16:25565
    at io.netty.channel.nio.AbstractNioChannel$AbstractNioUnsafe$1.run(AbstractNioChannel.java:213) ~[netty-all-4.0.23.Final.jar:4.0.23.Final]
    at io.netty.util.concurrent.PromiseTask$RunnableAdapter.call(PromiseTask.java:38) ~[netty-all-4.0.23.Final.jar:4.0.23.Final]
    at io.netty.util.concurrent.ScheduledFutureTask.run(ScheduledFutureTask.java:123) ~[netty-all-4.0.23.Final.jar:4.0.23.Final]
    at io.netty.util.concurrent.SingleThreadEventExecutor.runAllTasks(SingleThreadEventExecutor.java:380) ~[netty-all-4.0.23.Final.jar:4.0.23.Final]
    at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:357) ~[netty-all-4.0.23.Final.jar:4.0.23.Final]
    at io.netty.util.concurrent.SingleThreadEventExecutor$2.run(SingleThreadEventExecutor.java:116) ~[netty-all-4.0.23.Final.jar:4.0.23.Final]
    at java.lang.Thread.run(Thread.java:695) ~[?:1.6.0_65]

In both cases, when we check my friend's server logs, it looks like the server is running properly, and it never receives a request from my client to join the server.


These are some things we've already tried:

  • We've double- and triple-checked our router's port forwarding settings. They are certainly correct.
  • As you can see above, I've tried to connect to the server using both its internal and external IP addresses.
  • We've made sure that his Windows Firewall settings and my Mac OSX firewall settings aren't blocking Minecraft on either of our computers.

None of these have helped.

I've also looked at these similar questions on Arquade, none of which have helped:

What are some other things my friend and I should check to better diagnose and fix our issues connecting to his server?

  • Have you tried to fully disable every firewall you got ? – kiwixz Dec 29 '14 at 15:07
  • 5
    Given that you are on the same local network I would suggest sticking to the internal IP as you debug this, it will take port forwarding out of the picture as a possible cause. With that said as I first step I would make sure that you're computer can talk to his at all, by running a ping command from a bash window. – Phaeze Dec 29 '14 at 20:35
  • 4
    Also looking at your local IP I would verify you entered it correctly: the standard is 192.168 your log is showing 168.192 (this very well could be correct, its just not standard) – Phaeze Dec 29 '14 at 20:36
  • @Phaeze You're right, I was using the wrong IP address. xP When I tried it with the correct IP address, though, I got the same error. I edited my question to show the log entry when I use the correct IP address. – Kevin Dec 30 '14 at 9:53
  • I'm able to ping both the server's internal IP address when my friend's computer is running and our external IP address. – Kevin Dec 30 '14 at 10:00
3

Here are some more things to try before giving up:

  1. Check that in your friend's server.proporties the server-ip is set to your friend's internal ip NOT localhost or 127.0.0.1
  2. Try with a LAN server, have your friend open a world to LAN (with cheats) and type the command /publish, this will give you the port you need to connect to so connect to 192.168.2.16:[whatever port minecraft gives you]
  3. disable any and all firewalls, and then try connecting on a dedicated and a LAN server as in suggestion 2
  4. Try hosting the server on your end, it may be a mac protection problem or a java problem on his computer. Remember suggestion 1 as you reconfigure your new server. Also try a LAN server form your end.
  5. Try a new port/check that nothing is using 25565. Although I doubt this would be the problem its is worth a try.
  6. Make sure your router firewall allows your local traffic through, I can't tell you how to do this for your router but give the firewall or DMZ tabs a check to make sure nothing funky is going on.
  7. Although I doubt this will work, you can try setting online-mode to false

Best of luck, I hope this helps. I had something like this happen to me one time but with 2 macs and 2 windows, after two weeks it seemed to clear itself up.

2

When you are on the same network there is no need for port forwarding but you do need the port in the server properties (default 25565) matched with what you use to connect (for the default port 25565 you don't need to type it after the ip).

If you look for your ip I suggest you to go open cmd and type ipconfig. Now you have all your internal ip's, but you have to use the right one: ethernet or wireless ipv4. You might be using some virtual network ip like hamachi which will not work.

If you are on the same network I suggest to always use the internal ip because it might be faster.

-2

I think this is a port forwarding issue, have you tried hosting servers before? Your router may not be able to port forward.

Try installing LogMeIn hamachi. It is free and safe and will let you create a VPN (virtual private nework) and connect your friends to it. Then your friends will be able to connect to the server without Port forwarding.

  • 3
    He's on the same network and has tried connecting via local IP as well, so this isn't their problem. – Topperfalkon Jan 9 '15 at 17:09

protected by Frank Feb 18 '15 at 18:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.