I have tried to make minecraft run with more ram, but when I edit the arguments it seems that it can't create enough ram even for 2G. I have almost 4G of ram usable though. arguments: -Xmx2G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M

  • Can you post the argument(s) that you are using the increase the ram?
    – user73272
    Dec 29, 2014 at 17:57
  • Also keep in mind that these arguments are more of a max than an explicitly defined usage, the argument tells the JVM to preallocate that much memory, but it is very possible Minecraft itself won't ever reach that level.
    – user73272
    Dec 29, 2014 at 17:58
  • @Phaeze added them.
    – Eli
    Dec 30, 2014 at 21:45

1 Answer 1


Looking at the JVM arguments you are using I don't think there would be a problem. As I stated in my comment, the Xmx argument is a maximum setting and will only ever be reached if Minecraft has enough chunks loaded, so to put it simply having a higher Xmx value will allow to have a higher render distance set in game (this is an extreme over simplification).

That being said there is an additional option you can specify that will allow you to tell the JVM to allocate that memory immediately, rather than as needed; the option looks like -Xms2G. However this will only provide a very minimal performance increase if any at all.

I would also try removing the Xmn argument, this setting is used for things in memory that are short lived and it will likely be cutting into the 2G overall max (don't quote me on that I could be wrong)

I am not too knowledgeable on the other JVM arguments you have specified but I did find this article that mentions to avoid using both UseAdaptiveSizePolicy and CMSIncrementalMode and that UseConcMarkSweepGc and UseAdaptiveSizePolicy are contradictory settings

A quick final note, if you are trying to get Minecraft to use more ram to improve performance, it is much more likely that your processor or video card are performance bottlenecks here than your ram. I especially think this because you are already providing it with more memory than it is using.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .