3

this is what it shows:

[16:01:31] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker
[16:01:31] [main/INFO] [LaunchWrapper]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLTweaker
[16:01:31] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLTweaker
[16:01:31] [main/INFO] [FML]: Forge Mod Loader version 7.2.211.1121 for Minecraft 1.7.2 loading
[16:01:31] [main/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_25, running on Windows 7:amd64:6.1, installed at C:\Program Files (x86)\Minecraft\runtime\jre-x64\1.8.0_25
[16:01:31] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[16:01:31] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
[16:01:31] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[16:01:31] [main/ERROR] [LaunchWrapper]: Unable to launch
java.util.ConcurrentModificationException
    at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:901) ~[?:1.8.0_25]
    at java.util.ArrayList$Itr.remove(ArrayList.java:865) ~[?:1.8.0_25]
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:117) [launchwrapper-1.9.jar:?]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.9.jar:?]
Java HotSpot(TM) 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release

I already uninstalled java 8 from my computer. I don't know why or how it detects it. I've already downgraded to java 7 just so you know.

EDIT: I think I've found the problem. Minecraft keeps creating the java 1.8 runtime environment thingy instead of the java 1.7 each time I start Minecraft and I can't get rid of it by normal means (permanently deleting it in the recycle bin).

closed as off-topic by Frank, GodEmperorDune, Robotnik, Ben, user106385 Apr 21 '16 at 7:35

  • This question does not appear to be about videogames or videogame consoles within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 5
    I'm voting to close this question as off-topic because it is about tech support for modded Minecraft. We only provide tech support for vanilla Minecraft. – Frank Apr 21 '16 at 2:59
1

Go to control panel then to programs and features. Then unistall Java 8. Then go to the Java site and download Java 7 update 71. Java 8 breaks forge

  • As I said above, I already uninstalled it. – leo Dec 30 '14 at 4:02
  • 1
    you may have to change the runtime argument – user97039 Dec 30 '14 at 4:31
  • How do I do that? – leo Dec 30 '14 at 4:49
  • 1
    srry for delayed response open the mc launcher then go to profile editor make sure java 7 update 71 is installed. Click the check box on executable. Then copy and paste this into the box C:\Program Files\Java\jre7\bin\java.exe – user97039 Dec 30 '14 at 5:44
  • It may have to be C:\Program Files\Java\jre7\bin\javaw.exe mines not but my pcs weird lol goodluck @leo – user97039 Dec 30 '14 at 5:48
2

The newer launcher "keeps and maintains" it's own java. What you have to do is go to "Edit profile," and in the "Executable," box enter the installed version of java. (ex. C:\Program Files (x--)\Java\Jre-.-.-\bin\javaw.exe or java.exe)

Not the answer you're looking for? Browse other questions tagged or ask your own question.