While playing through Serious Sam II (PC) I found that some of the levels ended prematurely (as though the level were successfully completed).

For example, on the first level of planet Ellenier, Greendale, the level is supposed to end when you enter the castle after killing the two Big Spiders and Cannons that materialize when you approach it. However, the level often ends before that, once the enemies in the village have been killed, before the Big Spiders and Cannons are even spawned.

Similarly, in the first level of Kronor, Area 5100, the level is supposed to end after you enter the tunnel and kill all the aliens, then pick up the minigun that materializes. However, the level keeps ending early, after the other monsters outside are killed (and before the prisoners are even freed).

Later, while playing Serious Sam: Next Encounter (GameCube), I notice the same behavior in a couple of the bonus levels.

In The Silk Road, there is a gauntlet in which you fight numerous monsters, then at one point, you get in the combine to mow down even more monsters. Eventually, you get to the gates of the palace and enter to end the level. However, the level often ends whether or not you reach the palace. It definitely ends if the combine is destroyed or runs out of fuel, but even if you get in then get out and an unknown amount of time passes.

In The Geothermal Tunnels, you are in the submarine, underwater. Whether or not you take damage, eventually the air/gas runs out so it makes some sense that the level would end at that point even if you have not reached the end, though it could just as easily kill you, thus require reaching the end to complete.

If I ignore all the goodies, monsters, secrets, etc. and just go straight towards the end, I can get to it, but trying to get everything in the levels seems to cause this to happen. It seems as though there may be a timer of some sort, but if there is, where/when it is triggered or how long it has is unknown.

Another thing that they all have in common is that they all include vehicles, but then, there are other levels that include vehicles which do not exhibit this behavior.

Does anyone know what the trigger or triggers are for the levels or why they may be completing prematurely?

  • 3
    I don't remembering this happening to me but you may be right about the timer. You might be completing all of the main objectives quickly and then expiring the timer while going for the extras.
    – NickSuperb
    Commented Mar 15, 2012 at 20:46

2 Answers 2


I think this bug can be fixed by patching the game up to v2.070. You can download the patch from these sites:

  • 1
    Thanks for the suggestion, but I had already used the latest patch. Moreover, there is nothing in the changelogs that indicates they fixed it.
    – Synetech
    Commented May 24, 2013 at 19:08
  • 1
    Ok.....glad to help,buh could you jus.....ah never mind Commented May 24, 2013 at 19:33

Why not try to email Croteam or somehow post a bug with them? They will surely fix it at some point when they find out about it.

  • 1
    I’m not even sure it’s a bug. (Also, they don’t even seem to have a page for old games anymore, I doubt they make patches. ಠ_ఠ) I tried to add a comment (for whatever that’s worth) on the update page, but it won’t let me and says that I already have (I haven’t, so I suppose someone that previously had my current IP address must have done it).
    – Synetech
    Commented Sep 25, 2013 at 15:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .