1

I downloaded Town of Salem on Steam today and once it finished downloading I opened it and it said "Adobe AIR The installation of this application is damaged. Try re-installing or contacting the publisher for assistance." I'm not sure what to do, has this happened to any of you guys with any application? If so is there any way to get it to work? I've tried re-installing but it didn't work.

4
  • Have you tried... Re-installing Adobe Air? From the Adobe Air webpage? get.adobe.com/air
    – user92092
    Commented Jan 9, 2015 at 3:45
  • If it works, I'll post it as an answer.
    – user92092
    Commented Jan 9, 2015 at 3:46
  • No problem. xD I posted it as an answer too.
    – user92092
    Commented Jan 9, 2015 at 3:50
  • 1
    Sorry I forgot :P but ya thanks I did both!
    – Bucky
    Commented Jan 9, 2015 at 3:54

2 Answers 2

5

Well according to what you asked. You said "Adobe Air" needs reinstalling.

So, you goto the website linked here, and reinstall Adobe Air by clicking the Download button and following through with installation. :P

0

This is a fairly common problem due to your adobe air being out of date. We posted an announcement on the Steam group for the game here:

Steam Forums for Town of Salem

We plan on packaging an update for adobe air with the game installer in the future so this problem doesn't come up.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .