4

I recently upgraded the ammount of RAM in my computer, and I'd like to utilize it with Minecraft as I play frequently, with system intensive mods, such as shader mods. I've noticed from experience that Minecraft by default allocates, or will allow allocation of up to 1 GB, without modification. I know how to modify these amounts on vanilla Minecraft, by editing a game profile's JVM arguments, but if I try to do this with more than the default 1GB allocation on my Forge profile, the game doesn't start. I'll press play in the launcher, and nothing will happen, but If I change it back to 1GB then it starts as normal.

I've tried everything within my knowledge to fix this and now I'm out of ideas. I have more than enough RAM to safely allocate 4 GB at minimum, even with lots of other applications running, so i'd very much doubt that the problem is that I simply don't have enough availible RAM to launch with my ideal allocated amount.

I should probably note that because I run my own bukkit server and play on that so I can use Worldedit, My Minecraft Forge profile is running a 1.7.10 version of minecraft. The fact that I run the client application along with a server is not a problem, as I have a more than powerful enough computer to handle this, and have done so without problems many times in the past. Because I know it's likely to be asked, My reasoning for running a 1.7.10 server instead of one running 1.8.1 is that I have used bukkit for almost as long as I've been playing minecraft and do not want to switch to an official minecraft server, and bukkit hasn't been updated to 1.8.

Anyone have any hints to point me in the direction of utilizing my massive amount of RAM for Minecraft, or know how to make this work with forge just as it does with vanilla? Thanks!

EDIT: I should probably mention that, because I know people are going to ask, I am running a 64-bit version of the Java SE Development kit, alongside a 64-bit copy of Java 8 Update 25. I installed these yesterday, before I asked this question, afer reading many a tutorial suggesting that i'd need the development kit to alocate more RAM, but even after installing it, I still could not allocate more RAM. I got the same results with Forge, in fact, regardless of the version of java I had. Just to clarify again, My processors are both 64-bit, My windows 7 install is 64-bit, and my Java installs are 64-bit.

3

You're probably using 32-bit java. If your computer can support it download it here: http://java.com/en/download/manual.jsp.

If you do not have a 64-bit processor this will not work and ultimately you're doomed.

Another stackoverflow question that is more technical. https://stackoverflow.com/questions/17151919/how-to-increase-memory-size-for-jvm-beyond-1gb

  • Thanks for your answer, but as now stated by an edit to my question, Both of my processors are 64-bit, and so is both my OS Install and my Java install. – Ben Franchuk Jan 11 '15 at 23:51
  • 1
    I believe that java 8 doesn't work well with minecraft. Try installing 7. If that doesn't work please enter your java arguments. – Thomas Carroll Jan 12 '15 at 7:26
  • Thanks for that suggestion, I uninstalled 8 and am now using 7 and Forge seems to work fine with 2 GB of RAM Allocated. I'm currently trying different configurations of allocated RAM and seeing what kind of mods I can run with different configurations. – Ben Franchuk Jan 24 '15 at 7:27
  • 2
    Good to hear, hope it works for you! – Thomas Carroll Jan 24 '15 at 11:14

protected by Community Jul 2 '15 at 20:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.