5

I've just got a new System (i5 4690K, 16GB RAM, MSI GTX 970) and I'm expiriencing some weird mouse lag in certain games. To visualize, I've made a quick video:

I've tried several other games (FS:X, Arma 3, Space Engineers) and theres no issue there. Also no issue on the Desktop. I've turned off Windows mouse acceleration, tried V-Sync and no V-Sync with frames limited and unlimited in CS:GO, and tried turning off raw mouse input in CS:GO.

I also tried changing the polling rate of my mouse (G700) to 125, 250, 500 and 1000 which led to no change. This hasn't happened on my old system and It's also not happneing on my Mac with the same mouse. I have the latest Nvidia drivers (347.09). Frankly, I'm kinda lost.

  • Could it be your system isn't fast enough to handle the inputs? (Usually, this lag happens when there is not enough CPU power or RAM to process the mouse movement). Different drivers; devices have different needs (for example, graphics tablets require more memory and CPU power as it has a secondary program under it to limit the area of the screen the cursor can move around in etc.) – aytimothy Jan 17 '15 at 15:44
  • Also, have you tried restarting your computer? – aytimothy Jan 17 '15 at 15:47
  • I did try to restart. Here's my CPU load while playing CS: i.imgur.com/MlcmrmK.png Maximum 82% on any core. – Marv Jan 17 '15 at 15:52
  • 1
    You may want to flag it for a moderator to close it for you, since it was resolved, but no solution was found. – aytimothy Jan 23 '15 at 20:48
  • 2
    Just use 'other', since it involves a custom reason. – aytimothy Jan 23 '15 at 20:49
1

This method might work

  1. Go to Control Panel and search Cursor Options

  2. Disable Cursor Trails.

This might also work for Windows 8 only.

  1. Navigate to settings (go to the top corner, swipe down and click settings)

  2. Click Change PC Settings

  3. Click PC and Devices then click Mouse and Touchpad.

  4. Click the box underneath Touchpad and change to "No Delay"

This might work for Windows 7 and 8

  1. Go to search and type Change mouse settings.

  2. Click Hardware then click your mouse.

  3. Click Properties then Change settings.

  4. Click Driver

  5. Click Update Driver

WARNING: If the Update fails then click roll back then retry.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.