I've had some troubles from time to time with my XB1, as with any hardware I'm sure, but there are two in particular that bother me. Today I setup ME: Shadow of Mordor, and after installing etc. I booted the game and saw what I assume is the loading screen, but nothing happened for a few minutes, and then I was sent back to the home screen.

The most reasonable suggestion I found was that the XB1's default power state didn't actually turn it off, but into a sleep mode to boot quickly. As a consequence, the RAM may have residual data that would eventually crash the system, or otherwise. Hearing this, I went to the power options, only to find the screen was black, except for where the cursor was.

I managed to fix this by shutting down my XB1, pulling the plug and then holding the power button for 5 seconds or so, then retrying. I'm really curious as to what this does, just pulling the plug did nothing, along with all the other suggestions I tried.

So I'm wondering:

  • What might this solution actually do?
  • What could be the cause of this problem? Is the residual memory suggestion plausible?
  • Usually data in RAM is associated to a program or thread with a given PID. Data not assigned will be overwritten. the theory that "residual data" in the RAM crashes a system is, I believe, unfounded.
    – Eric
    Feb 1, 2015 at 10:42
  • I know that with a PC not closing text files when using their content for programming can hog RAM, I'd thought that maybe the instant on might not close programs entirely and have a similar effect. It wasn't my theory anyway, but I was curious about it.
    – Oman
    Feb 3, 2015 at 1:17
  • What you are referring to is a memory leak due to using resources and not freeing them after usage. There is no way to be certain what the one does but modern programming languages and software, especially when using up-to-date practices and testing mechanisms, face this issue less than you think.
    – Eric
    Feb 3, 2015 at 9:06
  • @EricTobias I'm a bit patchy on that sort of thing, but that was the context I imagined it in, thanks for clarifying
    – Oman
    Feb 3, 2015 at 9:50

1 Answer 1


I'd like to refer you to my answer (to my own question) here. I was given this 'fix' by a chap at MS support. And so far, for any issue I face with my Xbox One, this is the first thing I do. Specifically:

Clear Persistent Storage

Go to Settings -> Disc & Blu-ray -> Persistent Storage and hit "Clear Persistent Storage" - > This is apparently a non-recyclable "temp" area for the OS. I'm guessing that its public writable, which would mean that there may well be various lock files in there that could get corrupted, thus cause issues.

So far whatever I've come across, this little gem has fixed it instantly.

As for the "RAM" explanation. I've never had problems with leaving my Xbox One in quick boot mode. So I would imagine that may just be a coincidence. The Xbox One is a marvellous machine, but unfortunately not without it's flaws (like any new tech), as a result there are always some work-arounds required.

Give the Persistent storage a clear and hopefully this will sort your issue!

Hope this helps.

  • 1
    sometimes all you need to do is just power cycle as well to flush the RAM.
    – Rapitor
    Jan 28, 2015 at 15:50
  • A very interesting answer - I believe that the suggestion I tried may just be an alternate clear method, your suggestion seems a lot more plausible. I'll this next time I have any troubles. Thanks!
    – Oman
    Jan 29, 2015 at 1:22
  • Wait - I can't vote up an answer to my own question?
    – Oman
    Jan 29, 2015 at 1:22
  • Voting requires more reputation. Its fine, worry not, :) Jan 29, 2015 at 7:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .