1

Just recently, within the past 2 weeks, whenever I run the League of Legends launcher, the small splash screen pops up, stays up, and then is replaced by this window: enter image description here

Here are some of the fixes I've tried:

  • uninstalling League
  • pretty much everything in this thread

Does anyone have any advice on how to fix it?

  • Have you tried running league as admin? That solved many of my problems with getting the game to launch – Ben Craig Jan 30 '15 at 3:43
  • Yup, my default launcher is the admin launcher. – Despato Jan 30 '15 at 7:05
2

I had this problem a few weeks ago where nothing would work. If you've tried this, I apologize. My solution may be in that thread but I didn't see it. I had to change my DNS server to make it work. To do that:

  1. Open the network and sharing center
  2. On the left hand side click 'Change adapter settings'
  3. Find the adapter you're currently using
  4. Right click it and choose properties
  5. Click 'Internet Protocol Version 4 (TCP/IPv4)'
  6. Click properties, and modify it from:

enter image description here

to

enter image description here

By doing this, you are changing from whatever your default DNS server is to Google's DNS servers. If your DNS server is acting up, your LoL client won't be able to connect while Google's servers are working for me. If it doesn't work, you may want to change it back. Good luck!

  • Thanks so much! This fixed the problem perfectly for me. – Despato Feb 1 '15 at 11:23
  • didnt work for me :( – msm.oliveira Dec 8 '15 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.