18

I used to be a part of the "Tomb Raider Multiplayer Madness" Steam Group. They have regular weekly events. I became annoyed with the event notifications, so I thought leaving the group would cease them. I left the group. I'm still getting event notifications from the group. How do I stop the event notifications?

15

Apparently, with the new "Explore your Queue", when you choose to follow the game, it adds that game to your groups and it can only be removed through the community hub of that game.

Do not follow games if you do not want notifications from that game.

| improve this answer | |
9

In your friends list, there's two tabs - one for friends, another for groups. Click the groups tab, and you'll likely see the tomb raider group there. You can remove yourself from there.

If that doesn't work, go to the Tomb Raider community hub. There should be an unfollow button on the page:

enter image description here

Between these two locations, you're guaranteed to never be notified of any Tomb Raider events ever again.

| improve this answer | |
  • I am not following the group any longer on either of these tabs, yet I expect another event notification. It shows the green "Join Group" button for the group page. Is following different from joining? – NiteCyper Jan 31 '15 at 3:11
  • Just updated my answer now that I'm at my desktop computer. – Gigazelle Feb 1 '15 at 21:46
  • I'm having the same issue, I left the group but still getting notifications. – Jay Kyburz May 10 '16 at 22:54
  • 2
    This is the correct answer, at least for me. This stopped games from sending me constant weekly/monthly ‘event’ notifications, games I don't even play or remember buying. – ELLIOTTCABLE Oct 4 '16 at 23:31
4

You only need to open STEAM. Click "STEAM" in the top left corner, then click "Settings", this opens the setting window. Now click "Friends" and near the bottom locate "For Group events and announcements" and uncheck "Display a notification". This will stop the issue.

| improve this answer | |
  • 2
    Can not find "friends" in settings. – user18099 Nov 20 '18 at 17:09
3

Go to your name on Steam and click "activity" in the dropdown menu. On the top of the next page, click "friend activity settings" and from there you should be able to turn off all the popup notifications you don't want.

| improve this answer | |
1

Open FRIENDS > CLICK SETTINGS (gear icon) Then you'll see Group Events and Announcements at the bottom of the list:

Settings

| improve this answer | |
  • I think you mean 'Friends & Chat' - there is another 'Friends' button at the top which doesn't give access to Settings or Notifications. – Joachim Oct 22 at 19:08
0

I found it! As of 2020 Steam. Open Steam, click your Name under the bar:

[Store Library Community Your Name] (Takes you to "activity")

Then on the bottom right you'll see View Groups, and even Upcoming Events including the ones you are sick of seeing.

Click View all X groups.

Find whatever group won't stop spamming you with events and click Leave Group.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.