2

I've been playing League of Legends for some time now on a desktop, it was fine, my FPS was consistent at around 59-60 FPS. However, since my desktop is currently under repair, I am using a laptop to play League of Legends and sometimes my frame rate drops from 60 FPS to 1-10 FPS randomly.

I know that the internet isn't a problem because my ping is consistent at around 10-20. What could be the problem here? I set all my settings to Very Low and turned off shadows and everything, still the same happens.

Specs:

  • Processor: Intel(R) Pentium (R) CPU 2117U @ 1.80GHz
  • RAM: 8GB
  • System OS: x64 bit Windows 8.1
  • GPU: Nvidia Geforce GTX 780M
  • 2
    I don't know for sure how's that called but I'm pretty sure "lag" isn't the accurate term when it comes to computer performance issues. – Fabián Jan 31 '15 at 3:44
  • Not sure what it is too... I'll be grateful if someone can edit it to a better term :) – Kim Minseo Jan 31 '15 at 3:46
  • Are there certain times when it does this? Do you have other programs running? I have always played LoL on a laptop and since the SR visual update have no trouble running it at medium settings and shadows off. EDIT: I have an intel i5 processor @2.5GHZ and integrated GPU, processor is a step up but I have no idea on the graphics card. – VanBuzzKill Jan 31 '15 at 3:52
  • @Katustrawfic you can check your graphics card by: 1. Click Start. 2. On the Start menu, click Run. 3. In the Open box, type "dxdiag" (without the quotation marks), and then click OK. 4. The DirectX Diagnostic Tool opens. 5.On the Display tab, information about your graphics card is shown in the Device section. You can see the name of your card, as well as how much video memory it has. Anyway, my FPS gets worse everytime there is a huge amount of animations loading, but mostly it is quite random. – Kim Minseo Jan 31 '15 at 4:02
  • Your FPS drops a lot when in low battery. Literally from 70->10 – 54D Jan 31 '15 at 4:57
3

Here are a few things to check:

  1. Be sure you're using the graphics card and not the main CPU for graphics processing.

You should have a GeForce experience icon in your system tray. Right-click and open the GeForce Experience; make sure your GeForce drivers are up to date and go to the games tab.

Your game should be there with the best options for it. (I must admit I don't play LoL, but these things happened to me in the past.)

  1. Try to disable background tasks/processes like antivirus or subversion updates (some clients can be quite a pain) or something like it.

Anti-virus or other running programs could be causing slow downs. One way to isolate the problem is to disable/shut down all other running programs and services (Dropbox/Google Drive Sync/Anti-virus/etc.). If the problem is gone, try to re-enable your usual software one by one and see which one is causing the issue.

  1. Clean your laptop's fans

Another cause of slow-down I've seen was caused by a clogged laptop fan. It was causing the GPU/CPU to overheat which forces it to 'under-clock' itself in an attempt to cool off. This issue is really harder to fix because you need to open the computer and disassemble it in order to change/clean the fan.

  1. Try other games and see if you get the same issue. If you do, this would mean that it is not coming from LoL but from something else.

Otherwise, I would suggest to keep your Windows Task Manager on and quickly switch to it when your lag occurs, to try and see what takes up the CPU or the network or you memory.


Aside from these suggestions, it'll be harder to pin-point where the issue is coming from as we don't have access to the computer.

  • How do you check if I am using the graphics card and not the main CPU? – Kim Minseo Jan 31 '15 at 6:52
  • 1
    You should have a GeForce experience icon in your system tray, right-click and open the GeForce Experience; make sure your GeForce drivers are up to date and go to the games tab. Your game should be there with the best options for it. (I must admit I don't play LoL, but these things happened to me in the past.) – Bob R. Shake Jan 31 '15 at 7:03
  • Yeah it is up there... I am using GPI. I have one antivirus up, it's Avast free online security, can that be the cause? – Kim Minseo Jan 31 '15 at 12:47
  • 1
    I've updated my post, see my edit! – Bob R. Shake Jan 31 '15 at 19:25
  • 1
    I think it is most likely the case of overheating...I haven't cleaned up the inner parts of my com for quite some time... I'll try cleaning up my com and see what happens. – Kim Minseo Feb 1 '15 at 0:12
2

I also have the same problem. What I did was turn off Superfetch, then change the settings in game.config. I turned all ones to zero's, which kind of works but fps still drops when clash.

  • Hi user113713, welcome to Arqade! This section is reserved for answers so I've removed the parts asking for more help sorry. Once you have 50 reputation points you will be able to comment and ask for clarifications properly. – Robotnik May 26 '15 at 5:48
1

Ok firstly do what Bob R. Shake said. Its possible your computer isnt using the graphics card and rather the onboard graphics. Secondly, again do what Bob R Shake said, check for other clients or process running in the background. Now here is my advice:

  1. If you haven't already make sure to uninstall the pando media booster. This thing can cause some nasty problems and honestly I wouldn't be surprised if that was the cause.
  2. Go in game and check your FPS limit (it will be in the in game video settings). It might be on a cap or like auto or something.
  3. Go to C:\Riot Games\League of Legends\Config and take a good look in the video config. You might find something odd. I really am not sure what but just take a look.

Hope that helps.

Edit: Also, do you have a synology backup? There is a bug with that and fps so let me know if you do.

  • Neither of any of the option... the video config. file looks fine, and I don't have any FPS limit set in-game. For the first option, I don't think I even have the pando media booster installed... – Kim Minseo Jan 31 '15 at 12:48
-2

since you're using Windows 8.1, please try to configure your SuperFetch (C).
Start Run > type Services.msc > find Superfetch > right click for Properties > select Startup type: Manual > Stop service > restart your pc

enter image description here

  • Umm I don't think I should do this, especially since I am not using SSD... and even then, since Win 8 and 8.1 skips SSDs, this should not be changed from the default settings... – Kim Minseo Apr 25 '15 at 11:52
-2

Fixed my Framedrops by disabling Intel Speedtech.

Not the answer you're looking for? Browse other questions tagged or ask your own question.