2

My permissions.yml from PermissionsEx on a Bukkit 1.7.10:

groups:
  Jucator:
    default: true
    build: true
    permissions:
    - essentials.help
    - modifyworld.chat
    - modifyworld.*
    - essentials.tpa
    - essentials.tpahere
    - essentials.tpaccept
    - essentials.back
    - essentials.tpa
    - essentials.tpaccept
    - essentials.tpdeny
    - essentials.spawn
    - lwc.protect
    - preciousstones.benefit.*
    - preciousstones.alert.*
    - essentials.warp
    - essentials.warp.*
    - multiverse.core.spawn.self
    - bukkit.players
    - essentials.sethome
    - essentials.home
    options:
      prefix: '&7[Jucator] &f'
      default: true
  Donator:
    build: true
    inheritance:
    - Default
    permissions:
    - essentials.enchant
    - essentials.repair
    - essentials.tpa
    - essentials.tpahere
    - essentials.tpaccept
    options:
      prefix: '&6[Donator] &f'
  Flyer:
    build: true
    inheritance:
    - Default
    permissions:
    - essentials.enchant
    - essentials.repair
    - essentials.tpa
    - essentials.tpahere
    - essentials.tpaccept
    - essentials.fly
    options:
      prefix: '&6[Donator] &f'
  Moderator:
    build: true
    inheritance:
    - Default
    permissions:
    - essentials.repair
    - essentials.heal
    - essentials.item
    - essentials.fly
    - essentials.kick
    - essentials.mute
    - essentials.tjail
    - essentials.jail
    - essentials.tempban
    - essentials.vanish
    - essentials.tpa
    - essentials.tpahere
    - essentials.tpaccept
    options:
      prefix: '&b[Moderator] &7'
      suffix: '&7'
  Admin:
    build: true
    inheritance:
    - Moderator
    permissions:
    - essentials.gamemode
    - essentials.ban
    - essentials.day
    - essentials.night
    - bukkit.night
    - essentials.time
    - essentials.time.*
    - essentials.unban
    - essentials.ipban
    - essentials.unipban
    - essentials.pardon
    - essentials.enchant
    - essentials.tpa
    - essentials.tpahere
    - essentials.tpaccept
    - lwc.protect
    - preciousstones.benefit.*
    - preciousstones.alert.*
    - lwc.shownotices
    - essentials.weather
    - essentials.weather.*
    options:
      prefix: '&4[&cAdmin&4] &e'
      suffix: '&7'
  Owner:
    build: true
    inheritance:
    - Admin
    permissions:
    - '*'
    options:
      prefix: '&4[Owner] '
      suffix: '&b'
users:
  8c9be5f2-7cd0-3179-9280-5aed01008d14:
    group:
    - Owner
    options:
      name: iulyus01
  7a34a4e7-2afc-30e6-a869-29e9576f5042:
    group:
    - Owner
    options:
      name: artur99
  7415b45e-e551-3b34-b82d-7ca2b6775a50:
    group:
    - Admin
    options:
      name: paulcosmin
  bf236ddf-8c5d-344d-b9de-0a0c90d52d6b:
    group:
    - Owner
    options:
      name: McKing17
  c607d93b-aa83-3a0d-ae15-af88258399d4:
    group:
    - Jucator
    options:
      name: matei08
  lowdown:
    group:
    - Moderatori
schema-version: 1

I'm running these plugins:

PHPsend
WorldEdit
iConomy
CommandBook
Vault
Multiverse-Core
PermissionsEx
LWC
WorldGuard
Essentials
AncientGates
Jobs
PreciousStones
EssentialsProtect
Esse ntialsSpawn
SkyWars
EssentialsChat
AuthMe

For the players in the group "Jucator", almost no function is working

/spawn - not working    This whilte /espawn is working
/home - not working
/sethome - not working
/players - not working
/warp and /warps not working

I don't see what's the problem...

I tried adding essentials.spawn, essentials.spawn.*, bukkit.spawn even: multiverse.core.spawn.self, but still not working.

And tried also essentials.home, essentials.home.*, bukkit.home.

And also tried all the permissions for home, spawn and warp from here: http://wiki.mc-ess.net/doc/

Nothing is working...

Also made pex reload, and restarted the server several times, but the same problem...

The players get the message: You don't have permission!

UPDATE:

The new permissions.yml: http://pastebin.com/HspYRXyh, but same bugs...

5
  • I trie removing the Multiverse Core and restarting, and the same things...
    – artur99
    Commented Feb 5, 2015 at 17:31
  • Do you have everything spaced correctly? Commented Feb 5, 2015 at 17:31
  • I see that the Jucator group does not have an inheritance type specified. Is this intentional?
    – JvR
    Commented Feb 5, 2015 at 17:39
  • @LucidiousXIV yes everything is spaced corectly, i'm using netbeans and it does the syntax for me, and also, permissions like essentials.tpa could be edited...
    – artur99
    Commented Feb 5, 2015 at 17:52
  • @JvR, Jucator is the default group, it needs an inheritance?
    – artur99
    Commented Feb 5, 2015 at 17:57

3 Answers 3

1

Your inheritance tree looks odd:

  • Owner ← Admin
  • Admin ← Moderator
  • Moderator ← Default
  • Donator ← Default
  • Flyer ← Default
  • Jucator ← <nothing>
  • Default ? (not defined here)

The Jucators group does not inherit from anything, which makes me think it does not have any permissions you haven't explicitly assigned. All groups except the Jucators group ultimately inherit from a group called Default, which likely has permissions that differ from Jucator.

Having Jucator inherit from Default should fix this oddity.

7
  • 1
    Disclaimer: I have never worked with Yaml, PermissionsEX, Bukkit, or installed any Minecraft mods. Specifically, I don't know whether this is a best practice violation.
    – JvR
    Commented Feb 5, 2015 at 18:21
  • Jucator = Default :/
    – artur99
    Commented Feb 5, 2015 at 18:28
  • As you can see on the first 3 lines: groups: Jucator: default: true
    – artur99
    Commented Feb 5, 2015 at 18:28
  • and I tought inheritance: - Default will copy the permissions from the default group
    – artur99
    Commented Feb 5, 2015 at 18:30
  • 1
    @artur99 There is probably a difference between a group marked as default (player assigned here if no other group matches), and the group named 'Default', which may be provided in a different way. If you want to make sure, have your other groups inherit from Jucator instead, and see what happens.
    – JvR
    Commented Feb 5, 2015 at 18:34
0

SLOVED

I needed to delete the command block plugin...

And restart the server(the /pax reload wasn't enought) after any edit

-1

Do the permissions

  • Essentials.sethome
  • Essentials.home
  • Essentials.delhome
  • modifyworld.*

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .