I've just bought just cause 2 off steam. It played fine for about an hour, then it crashed. I thought nothing of it, until it crashed again ten minutes later. And again. So I looked on google and someone said to disable decals in the graphics options. I did that, and it was fine for ~30 minutes, and then it crashed again. My graphics options are 1920x1080 with high texture detail, 8xMSAA, 16x AF, high water quality, and generally high graphics options. Why am I crashing?

PC Specs:

AMD FX-6300 6 core processor
AMD Radeon R7 200 series graphics (1 GB VRAM)
Windows 7 64 bit

  • 1
    And here I thought I was the only one with issues playing Just Cause 2 for longer than 30 minutes per session on PC. I even tried to set all my graphics to the lowest possible settings, but that didn't fix the problem at all.
    – Nolonar
    Commented Feb 6, 2015 at 19:49
  • Have you set your graphics to low? It sorta sounds like an overheating issue.
    – Frank
    Commented Feb 6, 2015 at 20:53
  • @Frank i can assure you that it's not overheating, my GPU is up to 70 at most
    – imulsion
    Commented Feb 6, 2015 at 21:10

3 Answers 3


This is a common problem with Just Cause 2. I had the same problem (hard, repeated crashes to desktop) and now I can play Just Cause 2 for hours on end before running into the crash. It's not the decals (it can still crash with them off); they're just related to the problem and can make it worse, but are not the root cause or the way to fix it.

The problem is that specific graphics card driver builds and Just Cause 2 don't get along. The decals seem to more frequently trigger the part of the driver that causes the crash, so disabling decals can help reduce crash frequency, but not entirely eliminate the crashes.

The fix is, unfortunately, to downgrade your video card drivers pretty much at random. The exact versions reported to work longest without a crash differs depending on who you ask, so you're on your own to find one that works for your exact system.

I'm currently running nVidia's ancient 314.22 because of this problem. In combination with disabling decals, that was the only version that gave the longest spans of crash-free play for me (at the time, it was just one version back to downgrade to), and I've avoided upgrading ever since. I have to emphasise: I don't recommend this specific version as the fix, because whatever the bug is seems to depend on your exact system and card, so you will have to experiment.

  • I played for roughly 2 hours after posting this question without issue, so I can honestly say I have no idea what's happening. However, taking your answer to be true, I can't be bothered to downgrade my drivers and cause potential incompatibility with other games and have AMD yell at me every two seconds to update my drivers. Thanks for the answer anyway, I think I'll just have to deal with the crashes.
    – imulsion
    Commented Feb 6, 2015 at 23:06
  • 1
    +1 Disabling decals completely resolved crashing for me. Commented Jan 29, 2016 at 17:12

After some searching and experimentation, it turns out that the cause of the crashing is the Raptr desktop application. I thought it might have been GPU drivers but it transpires that's mostly a NVidia issue. If you're an AMD user make sure to turn off the Raptr app before playing. I messed around with graphics settings as well, pushing them up to their highest and this had no effect, so it seems that the Raptr app is the major issue.


What I done is, I stopped amd gaming evolved running while I was playing and so far I've player 30 mins without it crashing. Usually it would be 5 mins then it would crash. I'll edit this if it crashes.

Update been playing for over an hour now and have had no problems so i would recommend doing what i said above to stop the game from crashing if that does not work i have no idea But closing Amd gaming evolved when playing worked for me :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .