5

Some background:

Slightly over a month ago, Minecraft suddenly stopped working on my computer. There was no strange behavior of any kind prior to that. I have tried a couple of usual fixes, such as re-downloading and re-installing both Minecraft and Java (64-bit) itself. Unfortunately, neither of these fixes did anything. Cleaning the registry for leftovers from possibly corrupt Java re-install didn't help either. Then I have checked the firewall, to see if it conflicts with Minecraft or Java, and it doesn't. At last, I checked processes in task manager, and found that when I try to launch the game with the launcher, it creates a javaw.exe process for a split second, and the process immediately disappears.

Here's the log that I found in Minecraft's nativelog.txt:

########################################################
Native Launcher Version: 51  
Operating System: Windows 8.1  
Application Hash: b06079c75cb616544a6dbf83108db9a3265e1242  
Java Version: 1.8.0_25  
x64: 1  
Starting download of: https://launchermeta.mojang.com/mc/launcher.json  
Created pFile  
Content length is 00DF3F68  
Got 200 from server  
Download successful  
Started application ".\runtime\jre-x64\1.8.0_25\bin\java.exe" -cp "game\launcher.jar"   net.minecraft.launcher.Main  

Application can still run, so I assume that part's fine. When I launch Minecraft I do the following:

  • I use the newest Minecraft.exe official launcher (alternative Windows download, without built-in java).
  • After that I click the launcher to load, the cursor indicates that it's loading a file, and nothing happens.
  • As indicated by the background above, javaw.exe seemingly closes immediately after the process starts up.

So my question is, how can I get Minecraft back up and running?

My PC Specs:

  • HP Envy -15t Laptop
  • Windows 8.1 64-bit OS
  • Intel Core i7-4510U CPU @ 2.00GHz - 2.60GHz
  • 8GB RAM
2

I had a similar problem to what you're describing (albeit probably for different reasons, as I'm running a linux setup on a Chromebook); what ended being a passable solution for me was to use Magic Launcher:

http://www.minecraftforum.net/forums/mapping-and-modding/minecraft-tools/1262884-launcher-magic-launcher-1-2-6-mods-options

It's basically a launcher made to allow for mods to easily be loaded but I basically used it to circumvent the fact that I was having a problem with the official launcher. See if that works as a workaround until someone with a better solution can help out.

If you do end up trying it, I used Magic Launcher and ran the "test" launch from the settings menu before logging in with my own account.

Good luck!

  • I have tried to use the Magic Launcher, but it crashes on startup just like normal launcher - I can clearly see the javaw.exe process disappearing from processes tab in task manager. It seems that the issue is not in the launcher itself, but with my system (possibly some part of it is corrupt?) Anyway, thanks for pointing me in the right direction! – AlexB Feb 10 '15 at 1:38
0

Try to download and use Razer Cortex, select the minecraft launcher folder to boost the game then just start the game in razer and you are done.

0

Well, with the new minecraft launcher you don't need Java. What it does is bundle a slightly modified version; which will stop the bulk of those annoying security issues as well as make it perform a little better. I suggest you try that one or, if you're currently using that one, you can try the old one which does require Java. (Since you say it was working before, perhaps try that.)

  • You have those permissions now -- why not edit them in? :-) – Schism May 9 '15 at 16:45
-2

You might need to get a faster running minecraft or reinstall minecraft if your having problems.

  1. How to make minecraft faster: Hold Ctrl+alt+delete and it should bring up a menu (Note minecraft should be running at this time), then you should click task manager. You need to go to applications and find minecraft. Right click it and click go to process. Then you should right click the process and set priority and set it exactly 1 higher or this could lead to system damage.

  2. Reinstalling minecraft: Find minecraft and delete it. Then go to control pannel and find (Uninstall a Program) and click minecraft, it should uninstall automaticly. Then go to the minecraft homepage : https://minecraft.net/ . Sign in and reinstall .exe (Please note that if .exe doesn't work try .msi) and then reinstall every mod or anything you need like forge or optifine. I hope you found this useful from anything you need.

  • OP can't start Minecraft, which makes increasing process priority impossible. Not to mention that with the specs posted in the question, process priority will do a grand total of nothing unless OP is running other high-CPU applications simultaneously (very unlikely). Secondly, OP clearly states he already did reinstall the game. – MrLemon Oct 20 '15 at 8:11
-2

That happened to me too.

What fixed it for me was to log out and back in.

protected by Studoku Oct 21 '15 at 23:14

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.