1

When I click play on GTA 4 (steam) I get the Rockstar Social Club login (which I can log in fine), but after that this shows up:

SecuLauncer failed to start application

How do I fix this, so I can play the game?

  • That sounds like you're running something on your system that GTA4's DRM doesn't like. – Frank Feb 12 '15 at 16:42
  • Have you tried reinstalling the Visual Studio C++ redistributable and the .NET 3.5 framework? – necrosmash Feb 12 '15 at 16:50
2

From SecuROM's website:

Please note that this is a common issue when the Visual Studio C++ redistributable and/or Microsoft .NET Framework 3.5 was not installed properly.

  1. To solve the issue, please open your Windows Explorer/My Computer and switch to the following directory on the 'Grand Theft Auto IV' Disc #1: e.g. E:\GTAIV\Redistributable.

    If you own the Steam download version, please open your installation path of 'Grand Theft Auto IV': e.g. C:/Progra...steamapps/common/grand theft auto iv/installers.

    In that folder you will find a file called 'vcredist_x86.exe'. Please execute this application and follow the installation wizard.

  2. Please also download and install the latest version of Microsoft .NET Framework 3.5.

After you have successfully installed the Visual Studio C++ redistributable and Microsoft .NET Framework 3.5 please perform the recommended reboot. 'Grand Theft Auto IV' should start fine now.

Technically, this is something that Steam should have handled when you first ran it. But ensuring you have the correct dependencies installed should do the trick.

|improve this answer|||||
0

I was having this problem as well even after installing the Visual C++ redistributable. Turns out the problem was that the game does not like being installed on a drive that has NTFS Compression enabled. So if you have it installed on a drive with compression enabled you'll need to move it.

|improve this answer|||||
-1

Umm... I'm not sure id I should have this as an answer or a comment, but I managed to launch the game. I didn't do any fancy installing of any programs, I just waited about a week and tried playing it launching it again. It worked normally and now I'm playing GTA IV with no problems.

|improve this answer|||||
  • Steam may have updated the game files in that time, fixing the issue – Robotnik May 31 '15 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.