0

I have installed the recommended version of Minecraft Forge.

I am now trying to download "Single Player Commands". However, I have put the Single Player Commands folder into the mods folder, and when I open Minecraft It says that I have 3 mods, which is the pre-made mods including Forge. So there is no Single Player Commands there.

I have also tried dragging the WorldEdit.Jar folder into the mod folder, I have tried opening with different programs (WinRAR and File Explorer) I dunno if a compressed file explorer matters but if it does, how do I de-compress?

I have also tried following the manual installing instructions, but when I then change profile, set it to the new version I created and click the "Play" Button it says "Downloading 1.7.10.Mods.jar" and then it goes back to the Play button.

I am trying to copy a building from single player to multiplayer, but the world hates me, I'd appreciate any help highly, even if it didn't work. Please help me :v Have a good day!

closed as off-topic by Joachim, aytimothy, Schism, Ivo Coumans, Gigazelle Jul 29 at 18:58

  • This question does not appear to be about videogames or videogame consoles within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I may be mistaken but I thought SPC and WorldEdit didn't use Forge. Where did you download it from? What install instructions are you following? – SevenSidedDie Feb 13 '15 at 3:57
  • 4
    I'm voting to close this question as off-topic because it is about technical support for a modded version of Minecraft. – Joachim Jul 27 at 6:45
  • I mean I don't mind but why are you bumping this? – Minecraft_Noob Jul 28 at 15:55
2

First: You may have been scammed. Protect yourself.

SPC isn't available for 1.7.10. I have no idea where you got it from, and you should be suspicious because the only reason for a download site to claim it works with 1.7.10 is for nefarious purposes. The mention of automatically downloading 1.7.10.Mods.jar and then waiting for you to press Play again is especially suspicious, since there is no legitimate reason for a .jar file to have that name, and .jar files can contain code that can do anything it wants to your comptuer. Anything. It's probably malicious, and you should nuke that profile and its related folders immediately and start fresh.

Perhaps run a virus scanner and change your Minecraft password. Consider pursuing any other security measure you can think of that are appropriate after accidentally handing the keys to your computer to a masked stranger.

Copying and pasting your building

That alarm out of the way and security holes investigated, if you're just trying to get WorldEdit commands to do some block copy-pasting, you're in luck and don't need to install SPC.

You can get the WorldEdit Wrapper for 1.7.10, which will give you the necessary commands, and is installed just by placing it in the mods folder. It depends on LiteLoader (not Forge!) before it will load though, but it's an easy install.

But wait, how do I know those links aren't scams too?

To tie this to the first section, carefully note where those links I'm giving you lead: they're to minecraftforum.net (no hyphen! that one's a fake!), one of the few reputable locations to find mods for download (the others being planetminecraft.com and curse.com) — because that's where the actual people who make Minecraft mods advertise them.

Scammers are all over Minecraft like brown on toast, and have filled Google's search results with all kinds of tempting-looking download offers, often bundled with malware, viruses, and other nasties. Or just trying to scam a non-functional download to make some advertising money off you. (Scammers vary in their degree of scumminess.)

Never download a mod from a site you don't know and trust.

  • I tried what you said, although when I launched it with the WorldEdit Wrapper file in the mods folder and started Minecraft, it continued as if nothing ever happened.. Almost like the mods folder is broken.. I have tried deleting it and letting it reinstall itself, but it still does not work. I have followed the youtube tutorial exactly as well (the tutorial on the WorldEdit Wrapper page as well ofc) But it won't find it no matter what I try :v And yes, I had it as a .liteloader file – Minecraft_Noob Feb 13 '15 at 11:52
  • Definitely worth listening to this answer's word of caution. This is also why running "malfunctioning" programs as an administrator is almost always a gloriously bad idea. – JvR Feb 13 '15 at 15:03
  • @Minecraft_Noob And you installed LiteLoader first, and used the new LiteLoader profile in the laucher? Did the white Mojang screen have a red progress bar on the bottom? – SevenSidedDie Feb 13 '15 at 15:24
0

I believe the latest version of SPC is only available for 1.6.2, and the automated launcher is only available for 1.5 or older. You shouldn't need Forge at all to install it, in either case- the manual installation instructions for 1.6 don't say anything about Forge. WorldEdit.jar should go in .minecraft/bin, rather than .minecraft/mods.

Are you sure you downloaded a legitimate version of SPC? Could you provide a link to where you downloaded it?

Not the answer you're looking for? Browse other questions tagged or ask your own question.