3

I've recently got Thief (2014 version, on Steam) and I got a pc that can run 64bit executables and use the AMD Mantle technology but if I try to start the game without the 32bit mode I just get a black screen for few seconds and then it quit to desktop without any visible error or problem.

Any of you had this error and managed to use the 64bit version with Mantle enabled?

My graphic card is a HD 7900, according to the specifics I should be able to run Mantle just fine.

Thank you to all in advance!

  • Googling a bit turned up some possible issues: Do you have MSI Afterburner installed? Are your audio drivers up to date? – SevenSidedDie Feb 20 '15 at 18:58
  • Yeah, no MSI and my audio drivers are up to date afaik – Matteo Feb 20 '15 at 22:54
1

Some people have the same problem, but here is the solution. First, if you have more than 1 GPU, it's normal : Thief does not support (as of March 2014) multi-GPU. Maybe there was an update since then.

Of course, you have to check if you're using the latest drivers, and also if you uninstalled the previous one, to be sure they're not conflicting.

A user on a Steam community thread also said this :

Mantle seems to be incompatible with the setting "Depth of Field" set on "normal". Just use the "High" setting.

Here is the source : Mantle not working

  • Impressive, I believe I had done this several times, now it works, thank you – Matteo Apr 7 '15 at 8:14
  • You're welcome ! – V4karian Apr 11 '15 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.