1

I've researched the web carefully and went on about 20 pages, either from Steam itself or from this website or among other forums. Since I'm a StackOverflow user, I decided to give here a try:

I have steam on my PC for a long time. Not sure if I re-installed Windows at some point or not, but today I wanted to go back to play a few games so I managed to get Steam up and running again (D:\Games\Steam, deleted the ClientRegistry.blob and ran the steam.exe as Admin.) Apparently, Steam is running fine, it even recognize that I have Dota 2, Free to Play (the documentary) and Rocksmith installed (though needs update). But the one game I want to play (Left 4 Dead) it says it's not installed.

- If I try to install it, it gets stuck HERE:

enter image description here

- I can't repair it because ... enter image description here

I'm looking for ANY ANSWER AT ALL other than

delete the files of the game from [...]\common\steamapps\ and re-download everything

. Since Dota 2 and other games were easily recognized (automatically), I was hoping there were something I could do to avoid downloading billions of bytes again (it will take me more than 24hrs to re-download everything).

  • 2
    Have you tried moving the L4D folder to a different location, initiating the installer, pausing it as it begins the download process and moving the game folder back and then verifying integrity? – Elise Feb 26 '15 at 1:10
  • I just tried that. 1- Close Steam; 2- Remove the game folder; 3- Open Steam; 4- Start downloading the game; 5- Close steam; 6- When I went to the folder which I should place the game back, the folder hadn't been created by steam. Even so, I tried to place the game there and restart Steam, but it just kept going from 0.10% like nothing happened. Local File still shows Disk Usage: None. – Marco Aurélio Deleu Feb 26 '15 at 1:23
  • 2
    @Chippies I followed your instruction again, but this time I pressed the "Delete local game content", closed Steam and placed the game back and only then tried to install again. It was stuck for a while on "creating..." but then started to "discover existing files". Thank you. – Marco Aurélio Deleu Feb 26 '15 at 1:35
  • 1
    If that's what fixed it then it's probably worth @Chippies putting it as an answer, that way it wouldn't be missed by others. – MattR Feb 26 '15 at 11:51
  • 1
    @MarcoAurélioDeleu I added an answer. There's so many questions like this and usually I can't really know if my ways solve the problem until the asker confirms that it does, so I usually don't bother making an answer :P – Elise Feb 26 '15 at 22:19
4

You could try this:

  1. Move the game folder to a different location.
  2. Click on Delete Local Content for the game in Steam if available.
  3. Initiate the installer.
  4. Once it begins downloading, pause and close Steam.
  5. Move the original game folder back into where Steam is downloading the new files.
  6. Run Steam and if it doesn't automatically do so, verify file integrity.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.