5

I'm trying to make a Minecraft map that will move spectators in Spectator Mode around using armor stands. They will click the armor stand and use F5 mode to achieve the proper effect. However, they can see the armor stand. Is there a way to fix that and make a entity that even spectators can't see?

3 Answers 3

2

Spectators see all things with an invisibility effect or tag as if they were semitransparent. To get around this you need to use an entity that doesn't render, even without invisibility.

Prior to 1.8.2 this could easily be achieved with a WitherSkull, like this:

/summon WitherSkull ~ ~ ~ {direction:[0.0,0.0,0.0]}

When WitherSkulls have no motion they did not display. Unfortunately they "fixed" this in 1.8.2.

After 1.8.2, there isn't really a good way to do this.

The best I can come up with is summoning a WitherBoss, and then constantly setting its Invul tag (which changes its size) to a certain value:

/summon WitherBoss

/entitydata @e[type=WitherBoss] {Invul:10000}

enter image description here

Unfortunately, as you can see, the particles, shadow and boss bar are still very visible. IMO this is worse than just having a translucent baby chicken.

7

This is now fully possible as of 15w33a, using the AreaEffectCloud entity with a radius of 0:

/summon AreaEffectCloud ~ ~ ~ {Radius:0,Duration:216374}

The only way to see it is with F3+B:

enter image description here

2

THIS IS HOW I FIXED IT
I wanted to make armorstands invisible for spectators too, so I did this:

Make a custom Resourcepack- add a 100% transparent png file named "wood.png" in this folder: \assets\minecraft\textures\entity\armorstand.
Now add your Resourcepack ingame. All Armorstands will now be invisible.
You can do this with any other entity too. If you want them to only sometimes be shown you can just do a Custom Entity Model.

I hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .