The scrolling bug in Age of Empires II is rather well-known. It has been mentioned at Gaming, too. The problem is that, in-game, the view constantly scrolls to the left and upwards. And the game is totally unplayable. It happens almost every time I try to play the game, except for the rare cases when I have just restarted the computer.

  • I have not any Zune software installed.
  • I have a high-end computer running Windows 7 Home Premium, 64-bit, Intel i7 CPU and nVidia GPU, with the latest graphics drivers and OS updates.
  • The problem is resolved by a computer restart.

But it is not acceptable to have to restart the computer every time you want to play the game. At least not to me. In addition, I can't believe there is no other solution.

Indeed, a simple model of this problem is that there is a ScrewThingsUp flag on the computer. This is set to false when the OS starts, but is eventually set to true, by some (as far as I know) unidentified process. Has anyone identified this process? In any case, has anyone found a way to reset the flag to false?

  • Have you EVER installed Zune software? You might also want to check your startup items. May 7, 2011 at 17:12
  • No, I have never used anything related to Zune. May 7, 2011 at 17:14

8 Answers 8


That scrolling bug should be fixed by the community-made (non-official) AOE II: The Conquerors patch, UserPatch | https://userpatch.aiscripters.net/ :

This is a feature and bug-fix update for Age of Empires II: The Conquerors Expansion. Its primary focus is to correct several long existing issues with the AI system and related game elements.

Among many other fixes and improvements to AOE II: The Conquerors, one if its core features is:

Uncontrollable game view scrolling bug has been fixed

Notes: The UserPatch installer must be run with admin privileges in order for it to be able to install all of its fixes.

If you would like to simply enhance v1.0c, without upgrading to v1.1, you can hold the Ctrl key while clicking the Install button. This will block all v1.1 gameplay fixes, allowing for the use of v1.0c saved and recorded files. To do this via command line: SetupAoC.exe -c. Enhanced v1.0c mode is not recommended for normal gameplay. (Thanks to naxa for mentioning this.)

UserPatch installation guide

  • @AndreasRejbrand Let me know if it works. Also, if it fails, try running the patch installer in admin mode (might be needed, to ensure that all of its patches are properly applied). Dec 12, 2011 at 12:08
  • Just reports files missing.
    – Karlth
    Mar 11, 2012 at 14:05
  • @user357320 You can try reporting the issue at this forum thread for UserPatch or thru the author's (xOmicron) Twitter account. Mar 12, 2012 at 2:28
  • "to simply enhance v1.0c, without upgrading to v1.1, you can hold the Ctrl key while clicking the Install button. This will block all v1.1 gameplay fixes, allowing for the use of v1.0c saved and recorded files." To do this via command line: SetupAoC.exe -c.
    – n611x007
    Jul 10, 2012 at 17:14
  • @naxa Thanks for mentioning that. I've added that info into my answer. Aug 22, 2012 at 8:09

You tried shutting down all running processes and that didn't help. That zeros in on the running services.

Further, since you can uninterruptedly play AoK immediately after a fresh restart, but cannot when eventually that ScrewThingsUp flag is set to true, that means the service is set to Automatic (Delayed) Start mode (or even Manual mode, but the automatic one is more likely).

Sort your services by mode and run through all that are on Automatic (Delayed) mode. Stop non-essential services one-by-one and try running AoK after each stop. You should be able to find the rogue service.

If not, repeat the process with all Manual mode services that are currently running. Stop them, disable them, and test AoK.

Once you have zeroed in on one faulty service, permanently disable it (provided it is non-essential for any other task you perform).


I have made an important discovery. It isn't a solution to the actual problem, but it is a superior workaround compared to the full OS restart:

You don't have to restart the computer -- it is sufficient to log out [from your Windows account] and then log in again!

This I can live with. It will not even terminate important Windows services, such as the Windows Media Center Receiver Service that record TV programmes.

  • I can confirm this. Just logging off and logging in again saves the hassle of restarting.
    – user16445
    Dec 14, 2011 at 5:50

The Zune software isn't the only software known to cause this issue in Age of Empires II. Monitoring software from certain motherboard manufacturers such as Abit have also been known to cause the scrolling glitch as well.

I suggest closing down every application that you have open and in the background then trying to play the game again. If it worked, one of those applications is causing the problem and I would restart, wait for it to happen again, and go through the applications 1 by 1 and after closing a single app, try to see if you can reproduce the bug.

If all else fails, one rather strange fix was to unplug your mouse, shut down, then power your computer back up. Once you boot, plug your mouse back in and that should fix it. I believe this (oddly enough) was a permanent fix for many people.


which windows are you running? if vista, try going to your install folder, right clicking age2_x1.exe -> properties -> compatibility -> set to windows XP. that seems to solve many aoc-related problems.

also did you try to - pull your mouse out, then turn your comp off, turn it back on and then plug your mouse back in - scroll in the opposite direction, see if it stops then? - uninstalling zune software (before you do that i'd try ending all zune related processes in task manager)

if you unplug your mouse, does it still scroll?

If that still doesn't work, here's what fixed it for me.


( I am going to take a gander a this, since it has been unanswered for many days )

I had this problem a while back at college and at time the solution with any windows related thing used to be "format and reinstall", which used to work :P

However I checked the microsoft support pages and here is what I found

Game screen scrolls up unexpectedly When you play Age of Empires II, the map on the game screen may scroll up unexpectedly. To resolve this issue, contact your video card hardware manufacturer to obtain and install the latest version of the driver for your video card. For information about how to contact the manufacturer of your video card, see the "References" section.

It is also known to be a glitch in the mouse drivers which causes this. Here is what you can try.

  1. Start with a clean boot ( the "Restart the computer by using a clean boot procedure" section on the support page will help you ), see if you cannot cause the glitch, then you know that it is one of the start-up program that is messing something up
  2. Try to upgrade mouse drivers
  3. Run the game in compatibility mode
  4. As a last resort, when ever the glitch happens, try frantically scrolling in the opposite direction, it will go away.
  • Thank you for your reply. Well, the problem is never present after a normal reboot, so there is no need for a 'clean' reboot. I have tried with several mice and keyboards (and with drivers on/off), and I have tried every possible compatibility configuration, in addition to scrolling in the opposite direction. // One would suspect that there is some process that cause the issue. When the problem is apparenent (that is, not after a reboot), I have tried to kill almost every running process, but that didn't help... May 10, 2011 at 11:38
  • Oh, and I do have the latest video drivers. In fact, I have upgraded the video drivers two times since I first observerd the issue. May 10, 2011 at 11:40
  • compatibility mode ? May 10, 2011 at 13:33
  • Above I wrote "[...] and I have tried every possible compatibility configuration [...]". May 10, 2011 at 13:34
  • woops, my bad. didn't read carefully. From all that i could find, these things should've helped. I will modify the answer if I find something else. May 10, 2011 at 15:10

I found the Microsoft Mouse program(not driver) caused this problem...however it doesn't seem like your problem is from Microsoft Mouse.

  • 1
    You mean IntelliPoint? Unfortunately, I don't even have that installed... Jun 2, 2011 at 9:55

Has anyone identified this process? In any case, has anyone found a way to reset the flag to false?

I faced the similar problem several times and still do. In my case, a RE LOGGING fixes the problem. My personal experience leads me to its reason(in non-technical terms) being, it happens because I resumed from Sleep or Hibernate mode*.

I am keen to know, if anyone ever faced the problem after fresh RESTART ?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .