2

My PS3 Slim CECH-2501a was having some trouble, I think with overheating, so I popped it open with the help of ifixit's tutorial and cleaned it. After putting it back together however, I started having some problems. At first it gave me the red light indicating it was getting power, but not active. If I pushed the power button it would flicker green then go out completely.

Pulling the PSU to ensure everything was properly plugged in, it was, I put the PSU back and tried again. It turned on this time. I figured the problem was gone, so I unplugged it and put the screws I hadn't bothered with back in, specifically the torx security screws. Then the problem reappeared. Agitated I removed the torx screws and tried again, figuring I didn't care if they were out if my system worked, but it didn't do anything one way or another. A bit of online research and I decided to ensure my fingerprint oils hadn't gotten on the ribbon contacts, so I gently wiped a q-tip with alcohol over them to clean them.

That didn't work either. So I went on ifixit's Q/A site to get an answer. Only got one response, someone suggesting the YLOD, but that doesn't make sense because it's not giving my a yellow light at all.

Please help me fix my PS3.

Update: Got a new PSU and installed it, new PSU had the same problem. Leaves me to wonder if I might be somehow putting the PSU in incorrectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.