4

You can still click stuff, but it appears the mouse cursor is missing/invisible when I launch the game.

Online they say you can change the "compatibility" mode settings and fix this, but because I'm running through battle.net, it appears those changes don't seem to help.

1

Try using window mode (fullscreen). That worked for me.

Other solutions I read while searching for the same problem:

-Run as administrator

-Run with compatibility (Windows 7)

-Make Windows' interface smaller (right click on Desktop > Screen Resolution > Make items look smaller or bigger

| improve this answer | |
1

Some Blizzard titles also suffer from scaling issues with mouse cursors.

If you have any kind of "zoom" setup on your screen, found here Control Panel\All Control Panel Items\Display, anything other than "smaller 100%(default)" can cause the mouse cursor to disappear.

| improve this answer | |
  • Tried that. No love :( – Clay Nichols Nov 17 '15 at 22:51
1

I rebooted and it fixed the problem. I had recently changed DPI & resolution settings and something wasn't sticking.

| improve this answer | |
  • 1
    Standard first step of computer troubleshooting: "Have you tried turning it off and on again?" – Michaellogg Oct 17 '15 at 13:57
0

I just had a disappearing mouse issue after the latest SC2 patch. The problem was mouse trails. Disabled mouse trails and cursor reappeared.

| improve this answer | |
0

Aside from changing to windowed fullscreen, none of the above options worked for me on Windows 10 since the latest SCII update. What did work was

  • in Mouse Properties/Pointers untick "enable pointer shadow", and
  • in Mouse Properties/Pointer Options untick "hide pointer while typing".
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.