3

Apologies if this is the wrong place to ask this or I've overlooked something obvious, but I'm having some trouble getting a new server up and running.

It's a vanilla 1.8.3 server - ironically enough chosen as I thought it would be simpler with the current situation with Bukkit. I've tried all this with both the exe and the jar version. It's running on a Windows Server 2012 VM (hosted on a VMWare ESX server if that makes any difference). It has 6GB of RAM and I'm running JRE7u76. I have accepted the EULA, and the server is running without errors according to the logs.

The clients are running 1.8.3 as well, and can successfully ping the server by name. I've added server connections in the clients by machine name and IP, both with and without the 25565 port number added on.

I've added explicit firewall rules for 25565 for TCP and UDP, on the server and the clients.

They all just time out, and the server doesn't log any kind of error or failed logon attempt at all.

I'm basically out of ideas.. anyone?!


UPDATE: Looked deeper into the firewall as suggested by @Frank. I've enabled every logging option I can find on the firewall, and it would appear the server is not receiving any packets at all.

I've also done the same on the client, and can see no sign of that firewall either succeeding or failing to SEND any packets at all. At this point it looks like minecraft is simply not actually trying to connect to the server.

I've also added a well known online server (which is running 1.7.10) and connected without issue.

Just to be doubly sure, I've tried completely disabling the firewall on server and client to no effect as well.

Is this a 1.8.3 problem? (not that this makes much sense, as the client wouldn't know my server was 1.8.3 until it connected...)


UPDATE 2:

I've downloaded, compiled and hosted the 1.8.3 version of Bukkit, with much the same results.

However - when I run the server on the client machine and use localhost it works.

This means of course there is no specific 1.8.3 problem, and it is a network issue of some sort - but the server can see the client and vice-versa, and the problem remains even when I disable both firewalls completely.

Does anyone know of any other reason TCP access between the two machines might fail?

  • If a ping is working, but the connection isn't, I suspect it's not the correct port. Are they within the same network? – Frank Mar 7 '15 at 21:11
  • Yeah, it's all still on default 25565 port (just double checked the server.properties), and I'm sure it's network accessible as I'm RDP onto the server using one of the client machines. Is there a possibility the client default port has been changed? – Octopoid Mar 7 '15 at 21:16
  • I suspect that's probably what's happening. Obviously, the server name or IP is resolving properly, if you can ping it and connect via RDP. But usually, the firewall will log it. If they're in the same network, you'd double-check the server's firewall. If the clients are connecting from outside, you'd check the server firewall, and the network firewall. – Frank Mar 7 '15 at 21:18
  • Yeah, that certainly makes sense - However I've just double checked the firewall rules, and re-added the server in minecraft using "192.168.x.x:25565" - Same timeout behavior, no sign of any rejected connections in the logs.. – Octopoid Mar 7 '15 at 21:24
  • 1
    If you've determined that the issue isn't with the game, then I'm afraid we've offered as much help as we can; generic troubleshooting isn't in our purview. I'd recommend asking at SuperUser. – Frank Mar 8 '15 at 1:19
2

This is barely an answer, but it did "solve" the problem.

I flattened the VM and installed Server 2008 R2 instead.

As far as I know everything was configured in exactly the same way, and I don't doubt that you can get this running on 2012. I guess something just went wrong at some point during the install process or something.

At any rate, I've got a nice shiny new 1.8.3 up and server running now - thanks for your help!

0

Have you configured the router correctly then? Made sure the server have an assigned ip from the router and that the ports in the router are set to portforward to that ip? And made sure the routers firewall isn't blocking the connections?

Seem like there is a problem on the router, not the server.

When you try to connect from your own machine, if it's on the same network, do you try the ip that is used from internet to your router or the internal ip's within your network?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.