0

I was trying to install Far Cry 4 on my PS3 with the CD (not the PS network download), but it just keeps getting stuck at 72%. I tried deleting the game and reinstalling, the 1.6 patch, getting offline. I try to quit the game and start over again, and it is getting stuck at 30% or 31% sometimes I don't know why. What do I need to do to install the game from the CD?

  • 1
    Maybe the DVD is scratched? – Philipp Mar 10 '15 at 12:30
  • 1
    a friend was using the same CD on his ps3 and he actually can play it, so i dont think that is the problem – martin123 Mar 10 '15 at 13:32
  • Have you tried other games? I mean, can you narrow it down to just this copy of your PS3? – user101016 Mar 10 '15 at 14:38
  • i tried other games too and they work ok... i think i just did something wrong with the installation and messed it up in some way... i mean the first time i tried the ps3 was freeze so i require to reset the console, and then the game ask me to get more space so i delete some other games and after that this is happening (well thats what im thinking) – martin123 Mar 10 '15 at 14:47

Browse other questions tagged or ask your own question.