3

It has been some months since I've turned on my Playstation 3. Today, when I turned it on with my controllers, it didn't work. I thought "Hey, the battery surely ran out", so I tried to charge them but they don't seem to be charging at all. Could it be that they're officially weight papers by now?

  • 3
    Have you tried plugging them up to the PS3 via USB and using them like a cabled controller? if it's just the batteries not retaining a charge then this method will let you use them still but if not then either the battery is totally dead or the connected to the battery has came loose and you'll need to open the controller up which is a huge pain in the ass – Memor-X Mar 19 '15 at 22:52
6

If your PS3 controller has been unplugged and out of battery for a while, it wouldn't be able to maintain it's 'sync' with your PS3.

You will need to attach a USB cable to the PS3 and the other end to the controller for them to sync up properly again.


The other side of this, it's that the batteries in the PS3 controller have potentially degraded to the point where they will no longer hold a charge. If you leave them charging, but they switch off immediately once being unplugged, this is likely the case.

You should still be able to play games with them so long as they are plugged in to the PS3, but long term it might be worth investing in a new controller.

  • I see. Well, i plugged the controllers to the ps3 but they didn't charge. They only charged when i plugged them to the usb ports of my desktop. I'll see if they are holding charge tonight. I hope they still work :( – Joao Victor Mar 20 '15 at 12:20
  • If they charge from your computer but not your PS3, try switching the cables (assuming you're using a different cable on your PS than your PC, anyway). Could just be a cable problem. – gatherer818 Mar 21 '15 at 4:50
2

If you are having issues charging your controller, and you have used various usb cables, ensure that you are using the USB cable that came with the system. You will know what it looks like because it has that distinctive ferrite core on the cable.

enter image description here

0

You can also press the reset button on the back of the controller with a paperclip (hold for 10 seconds or so), plug in, then press the PS button. This may allow you to charge your controller.

Not the answer you're looking for? Browse other questions tagged or ask your own question.