I wanted to play C&C Generals and Zero Hours again and installed the game on my Windows 8.1 dell 15R N5110 laptop. But when i run the game the following error pops up and i can't open the game.

enter image description here

I have played the same game installed using the same files earlier on the same laptop. This is not even after a re-format/update of Windows 8.1. What should i do to get the game running. I have searched and found a common solution where i have to create the Options.ini file in the Game data folder in Documents folder. But that did not work either. Can some one please help to resolve this. I really love playing C&C Generals.

2 Answers 2


Adding the options.ini file is a start, but it is not all. You also need to run the game in Administrator mode, in compatibility mode for Windows XP Service Pack 3, and make sure to install the DirectX components pack from 2010, since it contains things these old games need which are missing from the more recent DirectX versions.

Also, on laptops, make sure to go to your Windows power management settings and crank them up to full; running in more "power friendly" modes tends to disable things that games need in order to run well.


Just go to the Documents, look for Command and Conquer Generals Zero Hour Data.
There you can find the options.ini: edit it or if not, just create it using notepad. Copy the following in it:

AntiAliasing = 1
BuildingOcclusion = yes
CampaignDifficulty = 1
DynamicLOD = yes
ExtraAnimations = yes
FirewallBehavior = 9
FirewallNeedToRefresh = FALSE
FirewallPortAllocationDelta = 0
GameSpyIPAddress =
Gamma = 50
HeatEffects = yes
IPAddress =
IdealStaticGameLOD = Low
LanguageFilter = false
MaxParticleCount = 2000
MusicVolume = 49
Resolution = 1024 768
Retaliation = yes
SFX3DVolume = 64
SFXVolume = 57
ScrollFactor = 79
SendDelay = yes
ShowSoftWaterEdge = yes
ShowTrees = yes
StaticGameLOD = Custom
TextureReduction = 0
UseAlternateMouse = no
UseCloudMap = yes
UseDoubleClickAttackMove = no
UseLightMap = yes
UseShadowDecals = yes
UseShadowVolumes = yes
VoiceVolume = 70

I adjusted the MaxParticleCount to 2000 instead of 5000.. that worked pretty fine with me. I looked for answers for a week and still nothing. So I did the DIY thing and it worked finally. That's the simple solution I found myself.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .