In the Sky Factory Mod Pack, I keep getting killed by player mobs standing over my bed that don't burn in sunlight. Every time I spawn, the game lags, I hear the sound of being hit about 8 times, and it puts me back onto the death screen.

Is there a way I can kill all the mobs crowding on my bed while dead in Minecraft?

  • ...just curious, how did that happen?
    – Matt
    Commented Sep 24, 2015 at 18:17

3 Answers 3


Try downloading MCEdit and opening up your world. You should see the mobs represented as red boxes around your bed; highlight them by clicking and dragging a selection around them, and then press Delete Entities. This doesn't remove actual players, but it will affect any items/xp on the ground, so be careful.

enter image description here


Assuming you are in single player, exiting to the menu, setting the difficulty to peaceful and reloading the world should remove all hostile mobs.

You can then change the difficulty back immediately and continue as you were.

  • Difficulty is now per world and can't be set from the main menu, so this may be impossible. Keep in mind that this will remove all hostile mobs everywhere in the loaded area, including boss and named mobs. Also, I'm uncertain but, I don't think Sky Factory player mobs are removed on peaceful.
    – SirBenet
    Commented Mar 21, 2015 at 17:23
  • @colorfusion Er, I still see a difficulty button in the main menu options... I was uncertain if every mod mob would be removed, but if they stay, that seems like a bug. Commented Mar 21, 2015 at 17:27
  • Regardless, it's still a viable method for vanilla and certain mod-packs. Commented Mar 21, 2015 at 17:32
  • My bad, I was looking at a 1.8 client; it is still present in 1.7.10.
    – SirBenet
    Commented Mar 21, 2015 at 17:34
  • Per-world difficulty is easy enough to change via an NBT editor though! Commented Mar 21, 2015 at 19:25

If you open the chat before you die by pressing the command button (By default /), you can enter commands while dead. This means knowing when you'll die and pressing /, the entering the command properly.

Edit: This has been patched as of 1.8.1, and will no longer work

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .