1

Direct X 11 is supposed to have Shader 5.0, so why is this happening when I try to run Dragonball: Xenoverse?

I am running the following setup:


System Information

  • Operating System: Windows 8.1 64-bit
  • System Model: HP ENVY m6 Notebook PC
  • BIOS: F.18
  • Processor: AMD FX-7500 Radeon R7,
  • Memory: 6144MB RAM
  • Available OS Memory: 5090MB RAM
  • DirectX Version: DirectX 11

I have tried updating all drivers in Device manager, and Windows says all are up to date. When I try launching the game, a black screen comes up, but nothing starts. Alt Tabing out shows there is an error window saying "Video Device Critical Error" and in the grey of the box "Shader model 3.0 or better graphic device required.

Shader model 5.0 is supposed to come on DirectX11, so I don't understand the problem. How should I proceed?

  • You need to clean up the question. A DxDiag should be complementary to the question, not the question itself. We shouldn't have to look for your system specs between lines of a report, you should provide them. – Zerjack Mar 25 '15 at 0:16
  • Alright. What system specs do I need to include? The part under the heading "System Information" has alot of the things I thought would be needed. What's missing? – Zephyr Mar 25 '15 at 0:21
  • It's not about what's missing. It's about making a proper question. questions must be clear, and concrete. Here is a good example of a question about technical issues. And telling us the full name of the game would be useful. I suspect you're speaking about DragonBall:Xenoverse, though you don't specify it. – Zerjack Mar 25 '15 at 0:29
  • Ok, I have tried to make it more clear. – Zephyr Mar 25 '15 at 0:37
  • Much better, (y). You're still not giving us a video card model though, I suspect you're using an integrated one? – Zerjack Mar 25 '15 at 0:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.