I have downloaded DSfix for Dark Souls, because I want to run the game at 60fps and at a higher resolution. I followed the install instructions, which are simply to extract the contents of the folder to the Dark Souls binary directory (where the Dark Souls executable is), and made changes in the ini file accordingly. But when I start the game from Steam, none of the changes take effect and the game starts up with all of its defaults in place. This is a fresh install of the Steamworks version, and my operating system is Windows 8.1. What am I missing?


1 Answer 1


The DSfix 2.4 works only with the steamworks version of Dark Souls, which at the moment is only available as beta.
Right click on Dark Souls in your library and go to properties, then go to Betas tab and select to opt in the steam version. Also, make sure you disable in-game anti-aliasing, as dsfix provides a better version of AA and is incompatible with in-game AA.
enter image description here

  • Just learned there is a non-GFWL version!
    – Yorik
    Commented Mar 25, 2015 at 19:12
  • Thanks, that seems to have done it. I didn't know I had to opt in to be running the Steamworks version...
    – Whelt
    Commented Mar 26, 2015 at 2:41
  • Yeah, they seem to be taking forever with the official switch from gfwl to steamworks, but the beta has been available since january, iirc, and it works just as good (better actually) as the gfwl version.
    – Elise
    Commented Mar 26, 2015 at 2:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .