2

Every time I try to talk to Ulfric Stormcloak he always tells me to talk to Galmar because he needs me to run an errand. But... Every time I try and talk to Galmar he always tells me something about Ulfric joining the Empire. They always redirect me to each other! I also can't start the "JAGGED CROWN" quest because this quest is getting in my way! It puts me in a constant loop of nothing! Any help would be appreciated! Thanks.

3
  • This happened to me. Try accepting/doing the quest you get from Ulfric to join the stormcloaks. After that you can do the crown quest. I put this as a comment, since I am not entirely sure how exactly it got fixed for me. But try to do the quest. – Izzo Mar 28 '15 at 19:58
  • Ok. Thank you for your advice! I'll see what I can do. I recall starting to become a Stormcloak then this quest getting in my way at the very end when I need to talk with Ulfric. Another reason why this may not work...? – KIDD_ZOMBIEZ Mar 30 '15 at 1:26
  • gaming.stackexchange.com/questions/93599/… Looks like this actually is a duplicate? Maybe you can find some more info in there. – Izzo Mar 30 '15 at 7:07
2

If you can load an earlier save point - Upon completing the objective in Joining the Stormcloaks, enter the Palace of Kings and proceed to the room where Ulfric and Galmar are debating and instantly talk to Ulfric. It requires multiple attempts of requesting to talk before he finally does but once he talks to you, you will be able to continue the Season Unending quest as normal.

-3

I've had this bug, which it is, too while playing skyrim a couple years ago. I had to reload an older save but it seems they have fixed it so maybe you need to update your game?

Maybe siding with the empire or at least get to the beginning of their jagged crown request will help you out and then try getting the stormcloak quest.(I havent tried this myself)

Check out the bugs section on this page and the discussion on this page.

That should help you out as much as possible and maybe you can add your findings afterwards.

1
  • 1
    I'm sorry, but I have to downvote this answer because it doesn't provide a solution to the problem which you confirmed to work. – Philipp Mar 28 '15 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.