1

Whenever I'm playing KSP 0.90, the game seems to crashes routinely about every 30-45 minutes, and whenever I look in the crash logs, it's always the same reason. The game usually crashes when I'm switching view, e.g, from the VAB to the KSC view. Most, if not all such errors look something like this:

Unity Player [version: Unity 4.5.5f1_7684ad0c5a44]

mono.dll caused an Access Violation (0xc0000005)
  in module mono.dll at 0023:1011926a.

Error occurred at 2015-03-28_103124.
C:\Users\Ethan\Downloads\ksp-win-0-90-0\KSP_win\KSP.exe, run by Ethan.
40% memory in use.
0 MB physical memory [0 MB free].
0 MB paging file [0 MB free].
0 MB user address space [118 MB free].
Write to location 00200000 caused an access violation.

I am unable to provide the entire crash log due to it's size, but you can find it here. Also, here is the list of mods I have installed as well. None of them are outdated.

  • BD Armory
  • Tweakscale
  • B9 Aerospace Pack.
  • DarkMultiplayer
  • PlanetFactory Revived
  • Ferram Aerospace (FAR)

Is there a reason as to why this might be happening? Are there conflicting mods? Or is KSP just really buggy with this many mods installed?

4
  • 4
    KSP, by itself, is pretty stable. It's probably a mod conflict.
    – Frank
    Commented Mar 28, 2015 at 19:35
  • Does it still crash regularly when you uninstall the mods? Commented Mar 29, 2015 at 3:09
  • @SevenSidedDie When I uninstalled the mods it crashed only once during one day. I'd like to have a way to keep the mods though, if possible. Commented Mar 29, 2015 at 13:44
  • This is a matter of simplifying, to isolate the problem. Was that single crash identical? Commented Mar 29, 2015 at 16:14

3 Answers 3

1

Best Solution: Run KSP in x64 Bit. Go into steam, right click on KSP, and click "Run in 64-bit". Its worked for me and I run a giant amount of mods. Happy Simming!

-1

One of the key things to do in identifying the culprit of crashes/bugs, is to find where they came from. In the example you give, it says mono.dll caused an.... You need to find where mono.dll is and try removing it (unless it's part of the game's core files) (make sure you remove the whole mod or part that is associated with the offending file, and also keep a backup copy of all the game files just in case you break it worse), then try to reproduce the crash again.

4
  • 2
    Isn't Mono the framework that allows .Net execution on Linux systems? That would make it a very odd error, as this is a Windows computer.
    – Flater
    Commented May 21, 2015 at 7:29
  • According to the log it's in the KSP.exe file, it's not like the name mono is reserved only for that one purpose. The only concern with using the same name would be a namespace collision, the risk of which is alleviated if it's run from the game's executable. Commented May 21, 2015 at 11:59
  • I wasn't technically assuming a reserved name. Just that since KSP is Linux compatible, and Unity is based on C#/.Net, that Mono is presumably going to be part of the files. It's just odd that it'd show up in a Windows version of the game. Given the location of the install directory, I'm assuming OP downloaded it from the Squad site, not Steam. And if it's part of the general KSP.exe, it shouldn't get called on a windows machine regardless.
    – Flater
    Commented May 21, 2015 at 12:02
  • After some more looking, I think you're right about it being that mono, but that raises the question as to why it's being called on a windows machine. If the problem is fixed when the asker deletes all mods, then it's likely that one of the mod's creators was lazy and/or inexperienced and didn't write the code correctly for all os's. The error discussed here is almost identical to what the asker describes in his question. Commented May 21, 2015 at 12:11
-2

It looks like you are running out of memory (RAM).

Try using active texture management from the ksp forums.

1
  • The error message says "40% memory in use", so this is unlikely. But when you still believe that whatever you suggest could help, can you please at least post a direct link?
    – Philipp
    Commented Apr 12, 2015 at 14:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .