3

I just bought Donkey Kong 64 on Wii U (Virtual Console version) and realised it's got black borders everywhere. The left and right side are especially large.

I thought I could fix it by activating Widescreen mode in the Options in-game, but all it does is squish the graphics, so they don't look stretched on widescreen TVs.

Is there any way I can force the Wii U to fill my screen completely, so I can play in widescreen mode?

  • 2
    the games were originally in 4:3 resolution. so that's probably what they are in the virtual console as well. – Rapitor Apr 2 '15 at 20:15
6

There's no way to get a true widescreen mode. Like Rapitor said, when these games were originally released as Nintendo 64 cartridges they only supported the standard SD 4:3 apect ratio, as that's the only aspect ratio TVs came in back then. The game you bought is the original cartridge version running under a emulator (the "Virtual Console") so the game has all the limitations of the original. It's not possible to support a true 16:9 widescreen presentation without updating the game in some manner to add that feature. For that you'll have to wait for a hypothetical HD remix version of Donkey Kong 64.

In the meantime just play the game. It won't be long before you stop noticing the black borders. Alternatively if the black borders really bother you, but squashed characters don't, you should be able to get the game to fill (most of) the screen by setting the Wii U to output 4:3 and having your TV stretch it to fill the 16:9 display.

  • This answer is true for most N64 games, but for the specific case of DK64 there is actually a menu option in the original N64 game that enabled 16:9 widescreen display. No additional pixels are used, instead the system would output a 16:9 image squished down into a 4:3 image and the TV would be responsible to stretch it back out. – Patrick Cavanaugh Apr 25 '15 at 3:33
  • @PatrickCavanaugh Yah, I wasn't sure from Jesse's answer if it was anamorphic widescreen or letterbox widescreen. I was hoping he'd give more details about his solution to make it a more useful answer. – user86571 Apr 25 '15 at 3:42
2

Try changing your tv settings under the screen mode, you should get a larger image that stretches it slightly, now go into your options on DK64 and change it to widescreen and it will correct the distortion. This worked for me, hope this helps!

  • Can you give more details about what screen mode? Is this setting on your TV, or the Wii U? – user86571 Apr 16 '15 at 21:39
1

DK64 like all Rareware games starting with GoldenEye 007 in 1997 supported true 16:9 WIDESCREEN native and dolby surround, infact some games such as GoldenEye featured a range of aspect ratios to play in. Nintendo did not support 16:9 for another 10 years, because they didn't have the technical skills to do so.

Judging by this it may take another 10 years before they add widescreen to their emulation.

It seems Nintendo have chosen the laziest option - apply one rule for all, a simple line of code in their emulator is all that is needed to allow gamers to toggle 4:3 fullscreen then 16:9 could be implemented in game menu as usual. As it seems 16:9 works in game but the Wii U still maintains the borders thus giving gamers a squashed image when enabled.

My original Donkey Kong 64 pal cartridges runs 16:9 widescreen without any borders.

  • Was the 16:9 specific to PAL? That seems magical. – Thebluefish Apr 3 '15 at 21:48
  • @Thebluefish I believe NTSC also supported 16:9. – highvoltage Apr 4 '15 at 14:02
  • @ Ross Ridge...Again please stop posting incorrect information. By the late 90's 16:9 CRT televisions were very popular. Nintendo's fanbase throughout this era and the GCN era requested 16:9 in all Nintendo titles - Nintendo refused stating that 16:9 was not a popular format angering many fans. It was only with the Wii that Nintendo started supporting 16:9 due to market pressure and using it as a unique selling point. 480p was also a late patch on Wii by Nintendo on Wii due to an extremely disgruntled and infuriated fanbase. – highvoltage Apr 4 '15 at 14:14
  • As your answer is basically just a mindless rant against Nintendo, I don't find it a very convincing refutation of my own answer. It might help if you were to at least try to answer the question, like Jesse did in his much more convincing answer. – user86571 Apr 16 '15 at 21:43
  • The 16:9 in DK64 is using a technique known as "anamorphic" widescreen - essentially, the game is rendered as rectangular pixels that are wider than they are tall. When an anamorphic image is output to a 16:9 TV that is set to stretch the image, the aspect ratio appears correct. Since the Wii U is outputting the image in 1080p 16:9 with pillar boxing (black borders on left and right) many TVs aren't going to offer the option to interpret the N64 VC output as anamorphic. Some TVs will still support this. – Patrick Cavanaugh Apr 25 '15 at 3:27
0

It's possible. Nintendo did it as a marketing scandal. There's a few things you need, (homebrew channel, a custom one with 16:9/full screen, a application called wiilauncher, I'll get the links later). Use wiilauncher, go into config setup hook none, switch aspect ratio to 16:9, save config, and launch channel once you leave config.

here is the tutorial bit, so first your going to need yawmm which is right here https://sites.google.com/site/completesg/how-to-use/wad-manager make sure you get the one with vwii support it will say it!!!! next is http://www.hacksden.com/showthread.php/7814-Workaround-for-the-HBC-with-the-latest-Wii-U-update this is the download page for the custom hb channel with fullscreen support, choose your colors, you got dark blue, black and yellow... is that.. ok anyways once you have those files put yawmm in apps folder if you don't have one create one. it needs to look like this when you open your sd card (you can have extra stuff but I mean make sure it exist this way) (apps) (YAWMM_EN) and somestuff within that. ok once you checked that is place properly, get your other file (it should be a .wad) and put it on the root of your sd, aka when you open your sd card in a file explorer and haven't moved into any other folders. last but not lest you need wiilauncher (sorry i don't have a good enough rep since i Just joined look it up, it should be in wiibrew . org or something like that when looking in applications, it description should be a alternative to gecko os (gecko os is a cheat manager thing, but i found out that using wiilauncher without cheats allows it to be run in fullscreen) ). Ok do the same with with wii launcher like yawmm. Ok get your sd card in your wii u run the homebrew channel, run yawmm, and install your .wad file, this is why I said root because its just easy to find it, once that is installed leave yawmm and leave the homebrew channel, you should see a new channel, which is the color you choose, use that homebrew channel, now at last, run wiilauncher, I recommend you change your config, the reason why is so if you do have cheat codes (somehow) it won't run them which is why putting the hook type to no hook (disables cheat codes in its entirety) and set the aspect ratio to 16:9 aka fullscreen. and launch channel. I must tell you this trick might not work for certain vc, such as sonic the hedgehog, but super mario world, mario kart 64 super mario 64 (just a lot) wil work, note this is for wiiu in vwii mode

0

In the Wii U System Settings, under TV there is an option for Screen Size at the bottom of the page, where you can adjust a slider to change the size of content on the screen. After some trial and error, I found that the 4th spot from the right was the best for my TV's 'Wide Fit' mode, and now vertical resolution is maximized without any cropping. There are still two thin black bars on the side, but I think that's just the nature of the content being made for a 640x480 aspect than a 720x480 aspect.

-1

I had the same problem on my Wii U.

Before I started the game I changed the resolution to 480p and set the ratio to 4:3 instead of 16:9.

It fixed both my problems with dk64 and VC games on my vWii

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.