3

Whenever I click the icon on my desktop to get to Minecraft, the launcher loads as usual, like it should. But when I click the "Play" button, the launcher goes away, but then comes back saying this:

[17:15:14] [Client thread/INFO]: Setting user: kassidygallowway
[17:15:14] [Client thread/INFO]: (Session ID is token:7b2075512917473abe32b04ffd11b2a4:ce288cc1399b4266a07c19cc48d47531)
Exception in thread "Client thread" com.google.gson.JsonSyntaxException: java.lang.IllegalStateException: Expected BEGIN_ARRAY but was STRING at line 1 column 1
    at com.google.gson.Gson.fromJson(Gson.java:815)
    at com.google.gson.Gson.fromJson(Gson.java:768)
    at lu.b(SourceFile:151)
    at lu.<init>(SourceFile:43)
    at net.minecraft.server.MinecraftServer.<init>(SourceFile:155)
    at bpp.<init>(SourceFile:41)
    at avf.<init>(SourceFile:293)
    at net.minecraft.client.main.Main.main(SourceFile:124)
Caused by: java.lang.IllegalStateException: Expected BEGIN_ARRAY but was STRING at line 1 column 1
    at com.google.gson.stream.JsonReader.beginArray(JsonReader.java:338)
    at com.google.gson.internal.bind.CollectionTypeAdapterFactory$Adapter.read(CollectionTypeAdapterFactory.java:79)
    at com.google.gson.internal.bind.CollectionTypeAdapterFactory$Adapter.read(CollectionTypeAdapterFactory.java:60)
    at com.google.gson.Gson.fromJson(Gson.java:803)
    ... 7 more

I have no idea what this means (I dont know codes or anything like that). It does this over and over again, no matter how many times I press Play.

  • Welcome to Arqade! Having the full crash log is required, could you find out where it is (there are many tutorials online), then put it in a pastebin, then link to it? We can't determine the source of the issue without it. – Elias Benevedes Apr 16 '15 at 0:23
  • 1
    There is no crash log as far as I know. (I looked at many tutorials). What I posted up there was the Game Output. It has been doing this for quite some time now. I used to have an Incremental CMS problem, but then this came up after I fixed that. Is there anything else you would need to help with this? – Bridgette Apr 16 '15 at 0:36
  • Please, voters, stop VTCing this as 'Unclear' - It's perfectly clear what is causing this issue AND how to fix it. – Robotnik Apr 16 '15 at 1:02
  • possible duplicate of Is there a list of error codes for Minecraft? – aytimothy Apr 16 '15 at 5:24
  • 1
    @aytimothy - That question does not answer the problem. Not to mention that we're actually in the process of moving away from one big question to specific questions (like this one) for SEO purposes. – Robotnik Apr 16 '15 at 5:46
3

This is a known issue with Minecraft where it sometimes breaks some of the files that store its data. It means that the .json files in your Minecraft version folders are broken.

Fix 1 - Remove just the version folder:

Most of the time it's only one or two files in your current version's folder that are causing the problem. To fix this, navigate* to:

C:\Users\<your PC username>\AppData\Roaming\.minecraft\versions

and delete the version folder you are trying to load. Then start the game again, and try launching that version again, which will force Minecraft to re-download it.

You can navigate to this folder by either opening an Explorer window and copy/pasting the path into the address bar, or by pushing the Windows key and R at the same time, and typing %AppData% (with the percentage signs) into the prompt. Once there, open the .minecraft folder.


Fix 2 - Remove everything except your world saves:

If the above doesn't fix the issue, then you will need to try removing more than just your version folder: This is Mojang's recommended fix:

For some people, reinstalling fixes this issue. To do so, press your Windows+R keys, type in %AppData% at the dialog, and press Enter. In the window that appears, open the .minecraft directory, and delete everything except for the saves directory that you see therein. Then, try running Minecraft again.

Remove everything in your .minecraft folder except the 'saves' folder. The saves folder contains your worlds, removing it will delete all your worlds.


Fix 3 - Remove your world's statistics:

Sometimes, it may be the files used to save your statistics that causes the issue.

Carefully navigate inside saves folder to .minecraft\saves\<yourworldname>\stats and delete the files there. This will reset your stats (number of blocks broken etc) but may fix this issue.

References:

| improve this answer | |
  • I am not good with most of this, so how do I get to C:\Users\<your PC username\AppData\Roaming\.minecraft\versions – Bridgette Apr 16 '15 at 1:10
  • And for "Fix 2," do you mean delete EVERYTHING (even the other folders) except for the "saves" folder? – Bridgette Apr 16 '15 at 1:41
  • You have to type it into a File explorer address bar. Open up Start->Documents or 'Computer' etc to get a file window (or click the folder icon on the task bar), then copy and paste the address. Remember to change the 'your pc username' part to whatever your username is. And yes, remove everything except 'saves', and rerun Minecraft again, it should start downloading everything again. – Robotnik Apr 16 '15 at 1:43
  • @Bridgette - How did you go? If you're still stuck, it might be worth getting someone to help walk you through it in person, like a family member or a friend. Computers can be fickle things :) – Robotnik Apr 16 '15 at 4:54
  • 1
    I used Fix 2 And it worked PERFECTLY! Thank you so so so so so much! I really appreciate it. It works like a charm :) – Bridgette Apr 16 '15 at 5:02
-1

Deleting all the JSON files from the top server directory worked for me ... on a forge server with 117 mods. The downside (or upside, if you like hunting minecraft gophers) is that you start over at square one ... losing whatever the JSON files contained, so no permissions, bans, or achievements, those you begin to get all over agian... So you got that going for you <\ : |

So You don't necessarily have to delete everything in the folder, just the bad JSON file(s). Also, if you look in the JSON files directly I bet you can find the error, fix it, and keep everything; but i did't try that.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.