I have an ASUS n53sn-sz129v, which has an nVidia GT550m graphics card as well as the Intel HD 3000 on board graphics chip.

My problem is that when I start some games (GTA V and CoD: Advanced Warfare), the PC insists on using the weaker Intel chip, regardless of which card is actually active at the moment.

The GPU drivers are up to date and I also tried to reinstall them but it didn't help.

  • I tried changing all settings to high performance
  • I am right-clicking on the shortcut for the game and select the nvidia card
  • My laptop is plugged in

Some games work fine with the nVidia card; I think it might be an issue with 64 bit games.

  • Can you say what game you are talking about? It may be a game spesific problem. – DJ Pirtu Apr 17 '15 at 12:17
  • gta v but i had that problem before on call of duty : advantage warfare – Erman Sinan Turan Apr 17 '15 at 12:18
  • Did you try updating the videocard drivers? That's usually the first thing to try. – Kevin Apr 17 '15 at 12:22
  • as i said i did that – Erman Sinan Turan Apr 17 '15 at 12:22
  • gaming.stackexchange.com/a/72576/101452 This might help you. – Izzo Apr 17 '15 at 12:25

If you check your taskbar icons (next to the Windows clock), you should see an NVidia logo. Right-click it, and choose NVidia GEForce Control Panel (from memory, it's the second item).

In the window that opens, choose "Manage 3D settings" on the lefthand side.

You will now be presented with a window that allows you to customize:

  • Global settings (first tab) - These are the default settings that NVidia will apply.
  • Custom settings per .exe (second tab) - Here, you can define specific configurations.

For some reason, some games (in my case XCom) tend to favor the Intel HD Graphics. If you add your game's .exe to the list of custom settings, you can force it to use the NVidia card. (You can configure a lot more detailed options than just which card to use, but I'll leave that up to you to find out what you want to do with it. I usually just pick the correct card and do the rest of the configuration from in-game)

Sadly, I can't provide you with screenshots as I don't have my NVidia laptop with me at work.

Good tip: When adding an item, you will be shown a suggestion list comprised of the .exe processes you recently started. I tend to always start the game once (to test performance), close it, then go to the Nvidia menu. Every time, the correct .exe is the top suggestion because it's the last program I opened.

  • i know that setting and i did that but it doesnt work for this time :S – Erman Sinan Turan Apr 17 '15 at 13:41

Since my last answer is kindly deleted, I want to help him anyway. I try again. The problem is the combination of the optimus driver, a 64 bit game with DirectX and last but not least Windows 7! A fix of nvidea for Windows 7 is not to be expected. In Windows 8, 8.1, and 10 beta this issue no longer appears. (Self-test) So the simple solution is to upgrade the operating system. But I can understand if you want to continue to use Windows 7 and it is also possible to solve this with a few tricks yourself. If you Erman Sinan Turan like, I would help you personally.

  • If you are going to add the way you fixed with an edit, I think that this answer can stay. – Ave Jun 1 '15 at 20:19
  • thanks for helping , actually i found the solution I reinstall windows 7 and it fixed the problem , I read something on net about this ComboFix deletes some nvidia optimus tech. files and that makes problem. – Erman Sinan Turan Jun 4 '15 at 23:02

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.